Multiple annotations of the same attribute

Hi guys, first time posting on the forum here - I was adding annotations to some observations and somehow two copies of each were added to this observation:
It was originally three of each but I removed the other two just to see what would happen and it seems that it’s an easy enough problem to fix manually, but I figured it would be good to post here to make sure there aren’t any underlying code issues or anything with the new Alive or Dead annotation. Thoughts, anyone?



I was not able to replicate, adding annotations to one of my animal observations via the observation detail page ( Wouldn’t allow me to add more than one.

On your example, did you add these annotations serially, all in the same window? Or might they have come from different windows open to the the same observation?

On yours I tried downvoting/upvoting some DQA items to force a reindex, but that didn’t fix it.

Welcome to the forum, and thank you for posting this!


Thanks @jdmore - I was simply adding them from the Identify page in one window, and after taking an abnormally long time to load it popped up with multiple annotations (despite the fact that I had only entered two). When I went directly to the page for the sighting they were still there. I can get rid of them myself by hitting the little x next to the annotation and that solves the problem, but I figured I’d leave it for now to see if anyone knew the cause


Thanks for posting this here @matthew_connors, I’ll see if our developers can take a look.


I can confirm, it added 3 and 4 of the same annotation type yesterday for me.

Not only alive/dead, but old ones too.
And yes, the system was really slow with adding them, if I added all 3 annotations for the observation the last one wasn’t saved at all.

1 Like

I was playing around trying to replicate it and this happened! :joy:

I can’t replicate it the original way it happened for me, but this time I put in values for the all three annotations and only the first one saved, so I then put in the last two again at which point it loaded with those last two doubled. When I went to remove the duplicates it doubled everything again instead of getting rid of them, but this seems to be an artifact of the Identify page as the sighting itself has everything normal


I encountered this same bug today.

I started working through some of my recent observations to add annotations, using the keyboard shortcuts to add and to move to the next observation. After adding an annotation I saw the spinning icon indicating the system was working; it took a long time to complete, and sometimes failed to register the annotation.

After adding annotations to about four observations I went back to look at the previous ones, and found that duplicate annotations had been added. Then I moved forward to newer observations and found that annotations had been added before I even got to them!

Moving to the “Your Observations” tab, I found that the duplicate annotations were present in the observations that I had edited, but were no annotations had been saved in the observations that I had not really touched (but showed in the Identify tab). Clear as mud?

In the screen shot below, the only annotation I entered was Life Stage. The rest appeared auto-magically. Only the Life Stage was saved to the observation in this case.

I ended up adding them once and then move on to the next obs, then after a series of them I recheck and see how it looks from id tab, if it’s wrong (multiple added) I go to the obs page and check it there, most of the time it’s right on the obs page, and it’s more likely annotations will be lost than will be multiplied.

Yes, I can fix them manually. But I am not going to be eager to add annotations if I have to go back to recheck and correct them.


I have the same feeling.

1 Like

I tried a few more annotations, and was able to enter several with only one problem appearing. After entering annotations in several new observations using the Identify module, I went to one of the observations with duplicated attributes. I clicked on the X to remove a duplicate Life Stage attribute, and it was removed. Then I tried to remove a Dead or Alive attribute, but it did not go away. Then I moved forward and back to look at other observations, and all showed multiple duplicated attributes which I had not entered.

I moved out of the Identify module and looked at the observations I had just edited, and found that the apparent new duplicate attributes had not been saved. Then I went through the observations and manually removed any duplicated attributes from my previous session.

Returning to the Identify module, I was able to add annotations with no additional errors. However, I avoided using the Dead or Alive attribute.

I noticed that adding Annotations was operating at normal speed (4-5 seconds from typing the letters until the annotation appeared on screen). The extreme slowness I saw previously was not evident this time.

Another one:

Noticed the same issue: If I add a second annotation while the first annotation is still being added (animated spinner), the first annotation appears to be lost, and I might be tempted to re-add it. However, if I reload the page, both annotations are present.

1 Like

Another one,. Observation was added 3 days ago, so fairly recent:
@jessicaleighallen, do you know if anything was happening when you annotated it?

I don’t explicitly remember this happening in the moment…but, I oftentimes have my annotations update slowly or revert back as if I had not added any at all.

As for duplicating…that issue happens to me in comments more often than annotations but the second (repeat) comment usually disappears upon reloading the page.

This one doesn’t have repeat annotations, at least that’s not what I see. It has two separate annotations with the same value.

It previously did. I didn’t take a screen shot because I wasn’t expecting it to resolve itself (none of the others have).

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings):

Browser, if a website issue (Firefox, Chrome, etc) : chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1:

Step 2:

Step 3:

Going through annotations, I noticed an observation where there were two annotations of adult for life stage by two different observers. In Identify I went to the next page and then back to previous page and this is what it looked like:

Then went to the next page. It looked like this:

After going back and forth a few times, it looks like this:

Here is one of the observations:

1 Like

That happens sometimes. It’s like it’s still displaying one set of annotations on additional observations. I can’t change that stray annotation. I can keep on annotating for read, but it gets confusing. If I stop annotating (and identifying) for a while it disappears. If I see it again, I’ll try to collect more information.

There’s a bug report about multiple annotations.

1 Like