New annotations won't save on certain observations

the problems you’re describing seem unrelated to this thread and more like the kinds of problems described over in another thread: these are temporary display / sync issues in the Identify screen which will resolve themselves if you reload the observation or reload the Identify screen.

the issues that seem to be caused by a lack of reindexing will persist until you trigger a reindex on the observation. in the examples in this thread, annotations had been added to the observation but did not display on the observation until a different change was made to the observation, triggering the reindexing of the observation. any attempt to add the annotation the observation while it had not yet been reindexed would fail (because the annotation already was stored in the database but was just not being retrieved an displayed properly).

I agree the permissions thing is most likely only tangentially I was just mentioning it in case it was related because I was experiencing it at exactly the same time as the other issues. But for the other I don’t know whether it is the re-indexing issue. Is there any way to tell if an annotation is present but not indexed without re-indexing it? I think in most cases where my annotation didn’t appear to save I would have just re-entered it, so I would never know if I was actually replicating this problem or not.

if the observation was in the bad state, you would not have been able to just re-enter the annotation. you would have had to force a reindex the observation, after which the previously effectively hidden annotation would have appeared.

Oh yeah, sometimes I do get like a ‘waiting’ swirl next to an annotation I tried to add which will never actually finish as long as I leave that page open and do nothing. Is that what you mean?

no. what i mean is that even if you close the observation and open it back up to try to add the observation again, it still won’t let you add the annotation. and every time you repeat that process, you still won’t be able to add the annotation. it’s only until you make another change to the observation that you resolve the bad state.

1 Like

For what it’s worth, I do also add the annotations very quickly with hotkeys usually, and I also see the issue where they sometimes show, then they don’t, but usually on a refresh they appear. This is the first time they didn’t stick for me visually but also didn’t let me resubmit.


I experienced the same issue and reported it here:

The workaround fixed it.