New flag not created, old flag unresolved if flag reason matches user's previous flag for taxon

A couple of days ago, I responded to this flag on Arpactophilus: I added the requested species and resolved the flag with the reason ‘added’ like I usually do.

A few minutes ago, I received this notification for the same flag:

straight away this seems odd, as note the timestamp; it says June 21st, which is when I resolved it, vs June 23rd today.

When I clicked on the notification, it takes me to the flag, and it’s now unresolved, even though I definitely resolved it

Even stranger, is that the notification has now evaporated. It should be right below the tag by lauriecookson in this list, and above the ellurasanctuary one:

This is the 3rd or 4th time this has happened to me in the last month or two. Is this a strange bug? There is no obvious reason why any user would go back through the list of resolved flags, find this, and unresolve it. Not to mention the fact this exact situation has now happened multiple times as I said, each involving a different user/original flagger, which makes me think perhaps a bug

1 Like

based on the comments now at, I’m wondering if there’s an odd bug where making a new flag on the same taxon causes it to disappear/be ‘absorbed’ by an older flag, and then unresolve it

(also noting I’ve now re-resolved this flag)

I’ve noticed flags I’ve resolved are sometimes unresolved without explanation, as well. The notification won’t list any user. I’ve not received a notification with text like yours (“Activity on a flag for —”), but it will instead say something like, “A user unresolved a flag for —” instead.

1 Like

ok I’m pretty sure this is a bug

not only does no flag exist for the new request, even though she said she made one, the flag has been unresolved again after I resolved it a second time

so the creation of a second flag on the same taxon by the same user unresolves the previous flag, and the second one gets absorbed and disappears


I’ve also seen the mysterious unresolve in the past a few times. I moved this to a Bug Report since I agree it does seem like a real phenomenon and unintended behavior.

My hunch is that the user creating a flag unresolves it in these situations which generates the notification. If this is the case, the user’s name should show on the notification and it shouldn’t disappear (which seems like a bug).

1 Like

I also just noticed it for the first time. I thought the flagger somehow unresolved it, but they weren’t a curator so I wasn’t sure.

another report of this bug:

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): iOS

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Safari

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I attempted to add a new Ceramium species (cliftonianum) via the ‘Flag For Curation’ facility. After clicking on the ‘Flag it’ button, the system did not create a new flag but instead referenced an old one that I had previously created on January 31 2024 which added a completely different species - which was ‘Ceramium monacanthum’. The system then also reset this old flag from ‘resolved’ to ‘unresolved’. The new flag content I had submitted today (28th June 2024) was not evident in the system. So I tried to create the new content again for Ceramium cliftonianum and attempted to submit it again via clicking on ‘Flag it’. This time I got a system error. Please see included screenshot above which said “We had a problem flagging that item:user already flagged that item.”

It’s as if the system can only accept one flag per user for a specific item (i.e. the ‘Ceramium’ genus in this case).

I have checked the list of flags and cannot see that my new flag exists anywhere. What is now apparent (on my dashboard) is an old flag from 31 Jan which is now showing as ‘unresolved’. You will be able to see from my dashboard and the iNaturalist species list that this old flag (of the 31st Jan) was previously resolved by @kitty12 shortly after I posted the request.

This bug also happened to me a few months ago. That is, I requested to add a new species to a particular genus where I had already previously requested addition of another species to that genus, with the result that the most recent request was lost and the old flag simply reset to unresolved.

Step 1:

Step 2:

Step 3:

same problem that I reported the other day:

hopefully there’s a fix for this

Yes. I just noticed your bug report in the list and because I’m new to this forum I couldn’t see how to link to your report. Thank you for linking.

I just tried replicating on our test server but couldn’t do it successfully. However, I may be missing a step, I’ll try again in a bit.

Non-curators can’t unresolve flags, so I don’t think that’s what’s happening.

1 Like

Tried a few more times and cannot replicate. I’ll let our developers know, they may have some insights.

this is still happening, very frustrating. Here’s another flag that just got unresolved:

I don’t see a new flag by the user that would have caused this?

based on some of the posts above, it seems like in these cases, the user attempts to create a new flag, but it doesn’t get created successfully. so you won’t see a new flag.


if i’m reading the other folks’ descriptions correctly, i think you can just find a taxon that you’ve flagged before which has been resolved and try to create a new flag on it.

1 Like

yes, i’ve tried that a few times today and last time, both on our test server and today in production, both as myself and with my test account which is not a staff account, and at multiple taxonomic levels. a new flag is created fine, old one stays unresolved.

hmmm… without digging into the code, i would just guess that maybe your new flag’s reason need to match the original flag’s reason exactly. not sure if you did that in your earlier tests.


OK, thanks, that worked. Will write up an issue.