Not remembering me when I log in

I log in directly: I don’t go into iNat via Facebook, google etc.
I use the latest version of Firefox on a Win 8.1 PC.

What is Private mode?

My understanding is that some browsers have a Setting such that you can turn on Private Mode, so that your browsing data is not being collected when you visit websites. One effect is that websites you visit do not show in your History. (That doesn’t necessarily mean you are not being tracked by the websites you visit, tho, just the browser.)

This may explain it better:

Thx. I don’t have Private mode switched on. Have learnt that you are meant to tick the box BEFORE you log in. So I have suggested that the login screen be re-designed so that the Remember Me box is ABOVE the log in fields.


14 posts were split to a new topic: I’m being automatically logged out of iNaturalist

Fwiw I dont think that it was intended that we should need to click “remember me” first…it just turns out that it is a workaround for this bug, or situation, whatever it is.
And…maybe unrelated?..for the last couple of days, when I go to the Forum from my home page on my desktop Mac in Safari, I have to log in to the Forum, and my pw is not available, and I dont know what it is. But from my Android tablet in Chrome there is no problem.

EDIT Sorry, I missed jdmore’s request to restrict this thread to iNat log in issues.
Anyway, I have requested a forum pw reset:)

POST EDITED AND MOSTLY REMOVED DUE TO CORRECTION NEEDED…Have discovered it was my mistake…re “… I can now confirm, in addition, that the signin page presented in the Android/Chrome issue with links in emails does not recognise my pw…”

I had not realised that the tablet was autocapitalising the first character, which of course invalidated my pw.

Sorry! Hope this correction reaches staff in time to prevent wasting time investigating it…

It’s vague, but I have had that issue with password not working sometimes. So, it seems that there was a box to click saying ‘Log In with iNaturalist’. When I clicked that, it logs me in. It’s just a bit quirky at times.

Yes, I am familiar with that quirk, and the one of sometimes having to go round a few times after it having accepted the pw, but since that quirk only takes a few seconds I have not raised the issue.

But it is another reason that being able to stay logged in forever, on all devices, would be just marvellous!


Okay, still having this problem. I just logged out, then in (making sure to click Remember Me before entering username and password), then logged out and in again - it did not remember me. This was within 5 minutes of each other, so a time limit can’t be the problem, and checking Remember Me first didn’t help. I’m using Chrome. It’s no big deal since I don’t log out much, I know my password, and it’s not logging me out itself, but just a heads-up that this is still happening.


I try to not use Chrome (privacy issues, Google, etc), but I opened it up now and it does have my username and password saved for me. If I go to Preferences → Autofill - > Passwords and search for iNaturalist, here’s what it looks like. Does this look the same on your browser?

Here’s what my log in screen looks like Chrome 88:


It has iNaturalist and my username under “saved passwords”, but there’s also a section below called “never saved” which includes That could be the problem.

It worked! I removed iNat from “never saved”, logged out, in (checking “remember me”), out, and in again, and it remembered me.

1 Like

For years, “remember me” worked with no issues. For the past few months, it never remembers me. I’ve tried Chrome, Firefox, my home computer, and my work computer. I’m not doing anything differently than previous years.


I had that problem with recent versions of Firefox. I think it is a problem with the new default level of tracking protection. I found that if I turn off “enhanced tracking protection” (via the shield icon next to the lock symbol on the left side of the address bar), then “remember me” works (after logging out and back on). Of course, this means you have to trust iNaturalist to not be doing bad things with trackers.
EDIT: That advice was wrong - it appeared to work, but then didn’t the next day. I have privacy settings default to removing cookies at the end of the session, and had an exception for inaturalis[.]org, but that wasn’t working. I found I had to go to privacy settings, click the cookie exceptions button, and delete the existing inaturalist[.]org entries, then re-enter inaturalist[.]org. Perhaps a bug in Firefox that somehow lost track of the exceptions?
EDIT: That only worked for a few days, then needed to log in again.

same general issue here, Chrome or Firefox. iNat is set as exception, permitted to store all cookies. Login is remembered for several days if I’m just IDing or browsing. After submitting new observations then closing/opening browser will always require new login.

I found a workaround that works for my system. Using a Firefox extension (Quick Cookie Manager), I modified the iNat session cookie to expire at a fixed future date rather than at the end of the session. This prevents deletion of the session cookie when the browser is closed. SInce then, I have connected a dozen or so times without being sent to the login page.

This is not really a proper solution, but it is working for the moment, with no adverse affects noted.

I seem to have found the solution for Firefox.
Settings > Privacy & Security > Cookies & Site Data (click Manage Exceptions) > enter to “Allow”.

After doing this, I was able to close Firefox, restart my computer, restart Firefox, and not have to login to iNat

Never mind. After coming back about an hour later, it required me to login. Since this is happening on multiple devices and multiple browsers, it must be the cookie that iNaturalist is feeding to my computer. And since it remembers the login for at least a few minutes, but not after an hour or so, it must be time-related.

1 Like

This has been happening to me a lot more often, too. I thought it maybe related to switching between iOS on the phone to iOS on the iPad, or using the iMac. Not sure.

Mine finally started working all by itself–on both my home computer and my work computer and on both Firefox and Chrome. I did nothing to alter any settings on any of these. It just started working one day!

1 Like