Observation audio plays loud hiss/noise

Platform (Android, iOS, Website): website

URLs (aka web addresses) of any relevant observations or pages:
Squirrel Treefrog (Hyla squirella) from Calhoun County, TX, USA on April 7, 2023 at 05:30 AM by Michael Orgill. 17 · iNaturalist

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

A fellow iNaturalist user alerted me that several of the audio recordings on my other account (michaelorgill) play a very loud hiss/deafening noise when he clicks play. I have not been able to replicate this on my device or another I have access to using Microsoft Edge or Google Chrome. He states that if downloaded, the files sound normal and it is only on the website where the problem occurs.

The files are being uploaded as .wav files on Microsoft Edge

Plays fine for me in Chrome, loud hiss in Firefox. Not sure what the issue is, but maybe something Firefox specific?

Perhaps it is related to this coding issue in the wav file?:


Same here. The file plays OK on Chrome (Mac) but I get nothing–not even a hiss–with Firefox (78.15.0esr (64-bit)).

1 Like

I’ve been coming across these occasionally for a while. When I’m not careful, headphones can go flying across the room. This one is noise in my Firefox in Linux as well as Android too. I’ve also had a few that just wouldn’t play in the player. I never checked those in Chrome, just downloaded them and played them in Audacity.


seems so. we’ve had other issues in the past noted in the forum related to Firefox playing certain sound files. as in those previous cases, whatever the problem is here, it’s almost certainly not an iNat problem. instead, the problem is likely some mix of Firefox and whatever you’re using to create your audio files.

what hardware (and software, if you’re using something to process recording) are you using to record (and save) the sound files? it looks like your file is 32-bit / 96kHz audio. are you actually recording at that bitrate, or are you doing something to bump it up after recording?

i took your file and just exported it at the same settings (32-bit / 48kHz per channel), and that re-exported file plays fine in Firefox. so i’m guessing that maybe you’re doing processing in some sort of software that is making files that are invalid in some way.


I am using Bandicam Screen Recorder to take clips from longer audio files that can be uploaded here, no other processing or editing.

If anyone has suggestions of a better method to crop/record a section from a longer file that avoids this problem, please let me know.

Audacity is free, and it doesn’t create problematic files, as far as i can tell.


I second Audacity. Free and never have had a problem.


I would suggest seeing if you can change the settings from 96Khz/32bit down to a lower setting like 48Khz or 44.1Khz at 24bit. It will not impact the “quality” of your recording to a listener as anything recorded above a 44.1 Khz sample rate is not audible to humans.

The 32bit vs 24bit difference would only matter if you were going to edit your recordings after capturing them to try and recover clipped sounds. Recording in 24 bit is fine for uploading to iNat if you aren’t going to edit. (Honestly, 16bit is fine as well).

Another easy fix might be to export them as MP3 files to avoid this WAV problem. The imperceptible quality differences wouldn’t impact their value on iNat.

That may be an easy fix that lets you keep using your current app/software.

It is clearly a Firefox problem with the WAV headers that your program is generating. Firefox claims to have fixed it, but I downloaded the newest Beta release of Firefox and the problem persists.


I’ve just tried to upload one using a different recording program ( Perching Birds (Order Passeriformes) from Calhoun County, TX, USA on April 23, 2023 at 09:10 AM by Michael Orgill. 15 · iNaturalist). Can somebody please let me know if this sounds better? Thanks!

this one plays fine for me in Firefox, and the file is much smaller, which is nice.

it looks like you’re recording on an AudioMoth device, which is designed to be able to record outside of the range of human hearing. if you did happen to capture outside-of-human-hearing-range audio that you wanted to post as a sound file, you would want to save it as a .wav with an appropriate sample rate that can handle the frequencies captured. otherwise, if everything is within human hearing range, then the process you used here is great.

That bird recording from Calhoun County plays normally (on Firefox).
What settings did you change so others will know if they come across the same problem?

I was not able to find a way to alter the settings in Bandicam to what you had suggested and have switched to using audacity.