Odd message when adding taxa to list

Given the recent rehaul of mantis taxonomy I had to update one of my lists (https://www.inaturalist.org/lists/2091805-Australian-Orthopteroid-Families) and came across a very odd message when trying to add the family Amorphoscelidae. I understand that lists are very buggy but I can’t find any reference to this particular message and I have no idea what it even means.

The other taxa I added were added fine but when it comes to this family I am able to find it successfully, but when I try to add it it tells me “must be the same as the last observed taxon, Paraoxypilus verreauxii”.


Some taxonomic background information that is probably relevant:
P. verreauxii was transferred from family Amorphoscelidae to family Nanomantidae in the most recent change and is my most recently-observed taxon that used to be in Amorphoscelidae (but is not my most recently-observed taxon in Nanomantidae under the new taxonomic changes). Under the new changes, I have not observed any Amorphoscelidae yet.

Has anyone come across this message before and can anyone offer a suggestion as to why it is happening?


Platform: Website

Browser: Chrome

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/lists/2091805-Australian-Orthopteroid-Families


I just tried refreshing the genus taxon page - does the error message happen still?

Can you share a screenshot of your list’s settings (edit screen)?

1 Like

Ah nice, that seems to have moved it along because now it is the same message but with a different taxon (Gyromantis kraussii). I assume we’ll probably have to refresh all of the genera that have moved. (How exactly do you refresh the taxon page?)

1 Like

@bouteloua how do you refresh a taxon page? I am having this problem again with Stanwellia

Click to edit the taxon, and then just save it without doing anything.

Hmmm I had tried that and it didn’t do anything. Still not doing anything now either. Could it be because spiders are a locked taxon?