Problem attaching sound observations from SoundCloud

Platform: Windows

Browser: chrome

Description of problem:

Step 1: In chrome I click “Edit” for an observation.

Step 2: Under “Add sounds” I select “SoundCloud.”

Step 3: The interface says " SoundCloud needs to confirm that you want your account connected to iNat. Confirm now". I push “confirm now.” I then get this page

image

Step 4: I push “Connect and continue”

I then get this:

If I go back to Editing the operation, I’m back at step 1 and do the same 4 step over again. It’s an infinite loop.

I did make a change recently that probably messed with Soundcloud integration, but I undid that change earlier today, so this might work now. However, it might not. Soundcloud’s API has not been fully functional for years (they no longer accept connections from new apps), so we can’t really guarantee that anything about that integration will work. The best thing to do would probably be to remove the ability to import sounds from Soundcloud. In the meantime, I suggest uploading your sounds directly to iNat.

1 Like

As I was about to say, iNaturalist has supported direct upload of audio files for a while now.

Still doesn’t work. I need to figure out how to do this now. I’ll do a separate post for this.

Hi Ken-ichi, I’d be very sad if SoundCloud recordings uploaded in the past might get lost at some point. Is there any option to migrate these to iNat?

We have already converted 9,493 of the sounds imported from Soundcloud to “local” sounds, i.e. ones where we have a copy of the file. I think the remaining 2,053 Soundcloud sounds cannot be be imported because the Soundcloud user hasn’t enabled direct download for that sound. At this point the best way to migrate those sounds to iNat is for each observer to just re-upload the sound file to iNat.

Still doesn’t work.

As @kueda said, there’s not much we can do about this, unfortunately, due to changes on SoundCloud’s end. If you have new sounds to add to iNat, please just upload them directly (tutorials here and here). I’m going to close this bug report.