Project Contributions Not Showing - User restriction not shown on project filters

iOS

2.8.7

I was added to a collection project for the area surrounding my house, I am on the roster and have taken pictures that are in the bounds of the collection. It seems that everything is correct, and that my photos are in the project, but none of them are showing up in the project’s page? I even went so far as to leave and rejoin, but that didn’t make my pics show up, so I deleted my account, remade, rejoined the project, and reloaded the pics; the pics still aren’t showing.

Step 1: Join Flora and Fauna of the South Belt

Step 2: Take a picture of the area in bounds

Step 3: Upload it (the project tab already has that specific project darkened and selected, I think meaning that it’s been manually added into the collection)

Step 4: Look at the project page, and see that none of my photos are there, even though the site says they are.

It appears that the project manager is only allowing observations by the following people to appear in the project:

Have you tried reaching out to the project manager? Whether this is a bug or intentionally limiting to this list of people, I’m not sure. These people should be displayed on the “About” page, but it doesn’t. https://www.inaturalist.org/projects/flora-and-fauna-of-the-southbelt?tab=about I was only able to see it by checking the json (https://www.inaturalist.org/projects/flora-and-fauna-of-the-southbelt.json) or when trying to join the project.

2 Likes

The issue is that the project creator has chosen both the Users requirement and the Project Members Only requirement, which is a bit counterintuitive. The system has to choose in this case, and it chooses the Users list. They need to either keep manually adding users and un-check the Project Members Only requirement, or delete the user list and keep Project Members Only checked.

1 Like

I think it’s working right, but just not displaying the full information in the user interface. To include your observations in the project, or not, it first asks “are you a member of the project?” and if the answer is yes, continue. It no, your observations won’t be included. The second question is “are you on the specific user list in the project filters?” and if the answer to that is also yes, your observations are displayed in the project. If you are not on the user list, your observations aren’t included. So it does effectively allow you to use both the “Project Members Only” option and the include users filter at the same time, as it should, but it just doesn’t display this full list of project settings in the user interface:

  • “Project Members Only” rule does not display on the “Join project?” page
  • List of users does not display on the “Read More” page when “project members only” is checked

(testing below)

bouteloua creates a project that only shows obs by zaht (1 qualifying obs), but then also checks Project Members Only. zaht isn’t a member of the project, so their obs won’t show up in the project anymore.

zeet (3 obs) joins the project:


and the zaht rule is displayed, but the “project members only” rule is not

going to the project’s “Read More” page, the “project members only” rule is displayed, but the zaht rule is not:
image


none of zeet’s qualifying obs appear in the project

But if you add zeet to the “include users” filter of the project, their obs do appear:
image

2 Likes

I hear you, but I honestly think that is a bit of a fluke. To me the issue is still that it doesn’t make sense to create a list of Users but also choose Project Members Only. It wasn’t designed to be used that way, hence the Project Requirements box not showing both requirements.