Restriction to place sticks around everywhere, how to clear for good

Platform: website

Browser: firefox on linux mint

URLs: n/a?


Description of problem: I have no idea if this is a true bug or a feature I am not using right. Shown in the images is how when I first visit the photos of a taxon page, it is restricted to Wisconsin, which is a restriction I put in looking at a different taxon page yesterday. Now it comes up automatically without me putting it there every time I go to “more photos”. I can clear it manually, as shown, but it is getting tedious to do that every time and when I refresh the restriction comes right back. I want to return to having no restriction to start out but cannot find a way to do that.

Step 1: restrict geographically while looking at photos of taxon page, say, to Wisconsin

Step 2: go to anywhere else, any other taxon, now no longer wanting to restrict to WI. Look at more photos. Become confused why there are only 8 observations of something when there should be more. Realize you are still restricted to WI.

Step 3: Manually click & clear the restriction. This solves it for the moment, on this one page.

Step 4: go to any other page or just refresh that one, restriction back. Try to find some way to clear it permanently. Not find anything.

On taxon pages, eg, there’s a white X in the green pill:


On the photo browser there isn’t:


If I click the white x to close the filter, that doesn’t seem to actually remove it. Are you clicking that x?

If I click on the text and choose “clear” that seems to actually clear it:


Are you able to replicate?

Yes! I am able to replicate on an individual taxon page, but when I refresh the page or go to any other taxon page, the restriction to WI is right back. That’s my main issue. More inconvenient than a break (I can always just keep removing it every time), but I assume it is meant to clear it for good, and still every time I try that it only clears it for that 1 page, that one time (again, goes right back even on that same page I cleared it from if I refresh)

Actually, doing a litte more testing it seems a bit more complicated…trying some other scenarios.

Although… I just went to test it again on “Fungi” and it seems like it also isn’t restricting to WI despite saying it does. Which is not what I remember earlier, so either it’s changed or I wasn’t noticing before.
It still has the restriction tag showing though so it would still be a “bug”, just a less problematic one

To clarify: the WI restriction green pill tag is always present now whenever i go to an observation, it can be cleared, but comes right back as described. But it doesn’t seem to actually be filtering anything.

(Also: thank you for looking into it!!)

Can you try a non-Wisconsin place? It looks like you have chosen Wisconsin as your default search place. Would like to eliminate that as a potential factor.

Yes I can: so here I just put Kentucky restriction on a fungi taxon I know doesn’t have any in KY (in part to quickly determine if it is actually filtering or not) & it filters

then I manually cleared the pill …

and that works.
But only for the moment. I refresh the page… and…

All is fine, really, from a practical standpoint (it is cleared)
but the green Kentucky pill remains

same thing happens now if I go to a new taxon page

It seems to be whatever the last place restriction I put in

1 Like

Thanks. I’ll write up a bug report this weekend, our developers likely can’t get to this until next week.


Now that I realize the lingering presence of the restriction marker pill isn’t really continuing to filter anything, I am much less concerned, even if it confuses me.

Whenever someone can get to it that’s great, not a pressing matter.

thank you for your work on it!

1 Like

Hey I was testing this more and it seems to have stopped happening! Which is great!
Not sure if that will keep on working but I will test more tomorrow & update if it is or not.

It is especially good because it was in that testing that I discovered the phantom pill menace actually was filtering after being cleared & reappearing after all… just it didn’t affect the first few observations, the first “page” of them I guess, and without scrolling down I wasn’t noticing its continued effects. So it was an actual problem secretly filtering everything I went to. So glad it is gone.

Checked again today & all is well, I assume someone fixed it? So I am marking the last post by tiwane as Solution - thank you again!

No one fixed it, I can still replicate the issue. Filed a bug report here:

Yes I came back here just now to change my report on that - it had seemed to clear up at the time, but now it is back. Not sure what to make of that but overall it does seem to still happen. I appreciate you filling the report!

Also, I found a simple broken link (goes to what I assume is an old version of iNat forums) on the site… not sure if that is a bug to report but in case it is useful I will just post it here

the link first is the iNaturalist Forum one, which goes here

then that link goes here

i can also make that a real bug report separately myself if that helps

I made a bug report in our team Slack, it looks like a simple fix. In the future, though, please make a separate bug report for each individual bug. Adding separate issues to an existing bug report makes it much more difficult to follow the original report.

Also, please don’t mark anything as “Solution” until the fix has actually been implemented and is live.

oh ok thank you!

This has been fixed.