Sound media file problem

Update: I now realise the problem lies with the “add media> add sounds” tab of the ‘edit observation’ page. It is greyed-out, one cannot add or remove files. So I’ve deleted a bunch of unnecessary information.

Can anyone replicated this? The following obs are at issue:
I need to remove the first sound file of this obs:

I need to remove the second sound file of this obs:

I need to remove both sound file of this obs:

I need to remove the sound file of this obs:

(Obs created using Chrome on Windows 7)

I am having the same results. You can add a sound by clicking the add photo under the photo on the observation page.

yes, that method and ‘drag and drop’ still works to add sound files. But you can’t add or remove from the edit page.

I can not add sounds files from my computer, either. I tried the suggestion from clay_s, but it didn’t work for me. How do I edit an observation to add sound files using the ‘drag and drop’ method ?

FYI, I read the earlier comments again closely, and found that they were correct. After the observation is submitted, you can view the observation, click on the right-most icon above the observation’s description, and browse to your sound files to add them. They cannot be added during an Edit Observation session. For my amphibian observations that only have sound files, I may have to submit them with nothing, and then add the sound files afterwards when viewing them (but not when editing them). It would be nice if this bug were fixed soon…

1 Like

Thanks for that tip. I also am not able to upload sounds via the sound tab on the Edit Observation page.

I can replicate, and have made an issue here:

1 Like

Is there any alternative way to remove the sound files other than through the edit page, or will we need to wait until the bug is fixed to remove sound files that were added to an observation by mistake?

It isn’t possible to remove sounds at all at this point, as far as I can tell. The only solution is to delete the observation and remake it from scratch.

1 Like

It’s odd that it’s lasted so long. What changed that can’t be easily unchanged?

I can replicate the identical problem in this thread. I uploaded a sound file that sounded okay on my phone, but was inaudible in iNaturalist. I edited the original file and uploaded it to the observation in the View mode. I then tried to delete the original in Edit mode, but the Add sounds dialogue is greyed out as in @
's post with an animated … just below and right of the Next >> button. If I click the Prev or Next buttons it simply changes to the spinning arrow animation forever.

@sallyslak has found a hack for now:

In batch edit mode you can deselect the sound files.

I have not tried this myself, so please let us know if this option works!


Thanks Marion.

In case anyone doesn’t know what I mean:

from your profile pic top right select “Edit observations”
choose “Batch edit” (next to add observations)
select offending observation
click edit selected
at the bottom of the observation click “sounds”
deselect at will.



Which browser are you using? Firefox does have some issues playing certain types of sound files, and there’s not much we can do about that.

OK, this fix should be in production now. I was able to delete a sound from one of my observations from the edit screen via the web.


I use Google Chrome. I wasn’t really complaining about the sound file not playing well, as I think it was very low and as I mentioned the edited sound file file sounded fine. I was mainly explaining why I wanted to delete the original sound file but could not, as I elaborated in my reply to this thread. Note the collapsed version of my reply only shows the first two sentences, and doesn’t show the whole reply. The system doesn’t cut off in the middle of a sentence, so it looks as though those first two sentences might be the full reply. Please expand the reply by clicking the down arrow character and you will see the full reply.

1 Like

Great! Works like a charm now. Thank you for the solution.

1 Like

Agree it now works, thanks tiwane.