Trouble embedding an external image into a journal post

At the very least, could you tell us which external hosting services will work? I just uploaded images to a shared album on Google Photos and to Flickr, but neither img src works in the journal post. All I see in the preview is the placeholder thumbnail that indicates broken code.

can’t tell exactly what you’ve tried since you haven’t provided an example, but probably one of these is the problem:

  1. invalid syntax
  2. public permissions not granted properly to the asset
  3. invalid reference to the asset

see https://forum.inaturalist.org/t/how-to-post-images-in-journal-pages/25862/15 and the rest of the thread for more information.

2 Likes

Here’s what it looks like in edit mode:

Here’s the preview:

In Flikr, I have it open to the “Public View” tab. I right-clicked the desired image and selected “copy link”:


Which of your listed reasons applies?

You’ll need to reference the link to the actual image, which would end in jpg in this case, e.g. https://live.staticflickr.com/65535/52318939335_d5e16f210f_h_d.jpg

image

2 Likes

How did you find that URL? I tried opening the image in a new tab, and the URL is still the same as the one in my original example.

As the owner, you might be able to right click on the image itself (I haven’t used Flickr in a while). I found it by clicking the download button (lower right corner), then hovering over the Large option and choosing “Copy link address”.

2 Likes

Right clicking the image itself was what I had originally done. But the download button worked. Thank you.

1 Like