Uploading observations between Android app and website not working for me

Platform Android, Website

App version number, if a mobile app issue 1.20.27 (458)

Browser, if a website issue: Chrome

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations?place_id=any&user_id=swainsona1&verifiable=any

Screenshots of what you are seeing
Android app

Website

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I refresh the observations on the app, a green highlighted notice appears at the top “Syncing…” then chances to “Preparing…” then changes to “Syncing 1 of 7 observations…” then the notice disappears.

Step 2: The observations recently submitted via the Android app (and not those submitted via the website) still have ‘Waiting to upload…’ and are highlighted with light green. They do not appear when I look at my observations on the website.

Step 3: I added an observation via the website and it did appear on my observations list on the Android app.

1 Like

Usually keeping trying to refresh page helps to start them synchronise, but if it totally doesn’t work - deleting them, reopening app can help, if it doesn’t help then try relogging in app or reinstalling it, but I hope it will be solved without that.

1 Like

I’ve had issues like this (usually when uploading over data) and eventually they go through. But sometimes they will upload (and get IDs from other users) before the app thinks they’re done. I’ve never had an issue over WiFi so I wouldn’t know how to help there. You can send logs to the iNat staff team by tapping on the version number three times.

1 Like

Thanks. I will send the logs.

1 Like