Weird plus sign and tools disappear on bulk uploader

I keep getting a wierd plus sign on my screen when I am editing a bulk upload. I am trying to combine photos of a single observation. Suddenly, a plus sign appears beside the cursor and all the command links like Combine disappear. I stab around at the screen randomly for a while and I can usually make the plus sign go away and the commands go back. Am I doing something wrong? How can I avoid this?

1 Like

Can you post a screenshot of what you’re seeing, please?

It just did it again…

But the print screen doesn’t show the odd cursor. I’ll try a phone photo.

Ok, so far looking pretty mysterious, particularly considering that “stabbing around the screen randomly” can fix it. Any chance you can open the Firefox Web Console and take a screenshot of that? There might be an error message there that’s informative.

Does it only happen when you’re combining photos or are there other actions that trigger this? Does it happen every time you try to combine photos? Any number of photos or just certain numbers? I’ve tried replicating this in Firefox (albeit on a Mac) but I can’t get it to happen.

End of the day…phone was out of juice. Had to find another device to get a screenshot with cursor.

1 Like

It doesn’t happen every time I try to combine photos. But lots of times. And sometimes it just happens. I wonder if it happens it my mouse slides as I click. Right now I’m stuck and doing a lot of stabbing.

And now the regular cursor came back, together with the regular command links. I clicked Esc twice, then clicked twice in the Description box…

Stuck again with that infernal plus sign. I think maybe it is related to clicking while the mouse is moving.

I tried opening the Firefox Web Console but it doesn’t look like there’s anything helpful there.

I’m afraid I’m stumped. Maybe try disabling some extensions, or updating to the latest version of Firefox, or try a different browser to see if this is isolated to Firefox.

1 Like

The plus cursor should appear when you select a photo and drag it. During the drag operation, the commands on the toolbar and side-panel should be hidden, and then reappaear when the drag is completed.

However, it sounds like this is sometimes happening for you even when you’ve not tried to start a drag and drop - after which, the interface gets stuck in a state where the mouse is not released properly. It’s not easy to diagnose exactly why this might happen, but one possibility is a faulty mouse. Many mice are made with cheap components that can wear out quite quickly. A common symptom of this is “ghost clicks” - i.e. the mouse seems to make clicks by itself without you pressing any buttons. Do you have a spare mouse that you can use for a while to rule out this possibility?


I’ve finally figure out that it consistently happens if I accidentally drag the mouse with the button down. And I can get rid of it by dragging the mouse through the description box with the button down. When I get the plus signs with the cursor, all the action links (like project and field entry, combine or delete disappear from the page. When I click and drag through the description box to get my regular cursor again, the action links come back as well. So there’s some sort of interplay between the page coding and the mouse actions. Odd.

1 Like