Wikipedia link opens page with json

Platform: Website

Browser: Firefox & Chrome


Description of problem: On the About tab the wikipedia info is shown but after clicking the link icon to the wikipedia article an empty page loads with only a json object.

Empty page url:

{“message”:“no id found”,“context”:{“properties”:[“P3151”],“value”:“1149223”}}

On other pages eg Mammals the link opens wikipedia as expected.

1 Like

When I follow that link it works as normal for me
*EDIT: nevermind, I misinterpreted the problem. Doesn’t work for me either

I think I’ve fixed it, by adding the iNaturalist taxa id to Wikidata item. I tried the link after the update and it worked for me. Can someone else test to confirm

For ref wikidata link:

1 Like

work, cheers for fixing :)

The missing iNat id on Wikidata may have been the cause, but the bug is the way the error was handled. iNat had managed to locate the wikipedia page as seen by the info on the About tab, but did not use that url for the clickable link.

Here’s another taxon with this bug:

Click on the link icon next to ‘Source: Wikipedia’ on the About/info tab, see clip from screen shot in first post.

Please don’t ‘fix’ this on wikidata, it applies to any taxon with an (english?) wikipedia page but no iNat id on wikidata

I’ll add to my report. Please don’t fix, leaving it as it is will help us fix the underlying bug.

Another taxon page with the same problem, in case you need more examples.

Platform: Website

Browser: Firefox on Linux

Description of problem:

Step 1: Click on “About” tab for this species

Step 2: Shows snapshot of Wikipedia page, as expected

Step 3: Clicking on the link does not bring up the Wikipedia page but this URL:

1 Like

Hi Peter, thanks for reporting - turns out there is an existing report about this issue so I moved your post here.

1 Like

it looks like this has been fixed: can anyone else confirm?

All the sample links above seem to work fine now, for what that’s worth.