Android app double posting

android-app
#1

How does this happen? Quite a few instances of this:
Essentially each observation has an observation without a picture but with locality, and another without locality but with a picture. Effectively each observation has a pair of observations with each others missing data.
Is there a way of easily repairing this?
see https://www.inaturalist.org/observations?user_id=cubs2ndbergvliet&place_id=any&verifiable=any

1 Like
#2

For the City Nature Challenge it means that the pictureless locality is included in the challenge, but the picture is not in the challenge (having no locality). It is not obvious what the best strategy would be when naming the observations.

#3

As far as repairing easily, I don’t think there is a good method. Best solution is probably for the user to delete the photo-only observation and upload that photo to the photoless one that has the metadata.

This is a known bug but we have never been able to consistently replicate it and thus it’s been tough to fix. One possible condition is a spotty internet connection, but I tried to do replicate it in the desert a few weeks ago and couldn’t do it. Best thing to do is get a log file from the app as soon as possible, but that’s often difficult because you wouldn’t notice this has happened until after you go to the website.

1 Like
#4

I have the same problem. How can you/ I prevent this?

#5

I’ve had this happen. For me, it seemed to be coming from uploading a photo that was no longer on my phone that had to be downloaded by my photo storage app. I use Google Photos and will delete photos that are backed up. I tested it out a while ago and had the observation post correctly while the photo was on my phone, but when I deleted the local copy and then went to do the upload, it did the double-post.

2 Likes
#6

As stated above, we need to understand the cause before we can fix it or provide prevention advice.

If you are choosing a photo from Google Photos, and that photo is not on your device, the app should download the photo to your device and the upload that copy. Is that not happening?

#7

It downloads the photo and then uploads it, but something in that process seemed to be causing an issue. I plan on taking some phone photos this weekend, so I’ll test it again to see if it’s still a problem.

2 Likes
#8

As soon as anyone experiences something like this, please send a log file ASAP form the app to help@inaturalist.org. The more information we can get about the conditions, the better we can replicate and resolve it.

#9

Yup! I messaged them about it earlier in the year when it started happening to me.

1 Like
#11

Instructions here:

1 Like
#12

Thanks, now I remember…

#13

another case: https://www.inaturalist.org/observations?place_id=any&subview=grid&user_id=bestfam&verifiable=any

unfortunately, too late - users appear unaware of the problem if using their smartphones. Only obvious on the web version afterwards.
I dont think the app crashes. I think that this just happens. Only detecting it because of checking blank observations for the City Nature Challenge. But can confirm it is Android - I have not yet come across any iPhone cases.

#14

another:
https://www.inaturalist.org/observations/23871906 & https://www.inaturalist.org/observations/23871833

and this https://www.inaturalist.org/observations/23956659#activity_comment_2859313 has no photo on the website, but apparently looks OK on the app.

1 Like
#15

another: https://www.inaturalist.org/observations/23886002

1 Like
#16

Another:
https://www.inaturalist.org/observations/23369590#activity_comment_2863720

Is flagging these going to help?
I requested users to leave these until the programmers had a look at them, but when can I ask them to fix them?

1 Like
#17

I’m pretty sure this is something we’ve addressed in the latest beta version of the app. If you’re already a beta tester, check the Google Play Store for an update (version 1.11.22, build 346). If you’re not a beta tester and want to try this out, check out https://play.google.com/apps/testing/org.inaturalist.android. If you test it out, please let us know how it goes. I still can’t replicate this issue and since it doesn’t cause a crash it’s hard to see in our log data, so we won’t know it’s fixed until people who are experiencing the bug tell us it’s fixed.

2 Likes
#18

Thanks! I had not realized there was the option to join the beta program. I have long enjoyed being on the so-called “bleeding edge” out beyond the leading edge, past where programs are stable. Beta is stable compared to alpha or nightly builds. I ran FireFox on nightly builds for years, every morning a new build.

1 Like
#19

@kueda

-Photo is still in my gallery, not deleted from my phone.
-I do not remember doing special stuff just imported a geotagged photo into iNaturalist and probably uploaded via 4G.

1.11.22 (346)
https://www.inaturalist.org/observations/24931067
https://www.inaturalist.org/observations?created_on=2019-05-11&place_id=any&subview=table&user_id=optilete&verifiable=any

1 Like
#20

@optilete it definitely looks like you posted https://www.inaturalist.org/observations/24931067 and https://www.inaturalist.org/observations/24931016 with build 346, but are you absolutely sure you created them with build 346? Given that the “observed on” value is today I suspect you did, just want to confirm.

1 Like
#21

I think around ‘’’‘vandaag …15:34 CEST’’ I imported a geotagged picture into iNaturalist Android app 1.11.22 (346) and the app automatically sync it with iNaturalist.org and made two observations. The geotagged picture is still on my phone.

If this is the time of upload I probably used wifi of Wikimedia foundation. It was crowded at that time so the connection might be not so well.

I installed the app 1.11.22 (346) at the day of release, so ( and now I understand your question) the observation is created and uploaded with the same version of the app: 1.11.22 (346) .

Same photo today gives no troubles: https://www.inaturalist.org/observations/24984463
I should think that in the morning USA sleeps and processing works fine but in the afternoon USA wakes up disturbs my uploads.
At what time are the ‘‘double postings’’ uploaded and what was the server load at that time?

1 Like