Problem with seeming duplication of observations on mobile app (Android) in previous two days

I’m having trouble with mobile uploads. I have it even with single uploads getting hung up, crashing the app, or duplicating the observation (at least on my end). I’m on Android.

Two days ago, I deleted one of the ‘duplicate’ observations and it deleted both. Yesterday I deleted a different duplicate, and it worked fine, though it did duplicate by itself.

I think it might be related to a recent update, since I downloaded that two days ago and tried uploading a few hours later.

I haven’t had any major bugs (aside from crashes) on the app for a while, so it seems likely. I don’t think I will be able to replicate the error, but I will update here with screenshots if it crops up again.

My iNat version is 1.25.11, not sure about the Android Version, Version 12 is all I can find (software updated 2 days ago).

Platform (Android, iOS, Website):

App version number: 12

Browser: N/A

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing : None available currently

Description of problem :

Step 1: Upload a photo through the app

Step 2: add ID and location, notes

Step 3: submit, wait for upload, ‘two’ observations appear

1 Like

I’m having perhaps a similar problem.
When I make an observation in the field, sometimes the app gets hung up on the camera ( I take the photo but it doesn’t register in the app somehow and gets stuck on the camera screen as if I hadn’t taken the photo). when this happens, usually two observations are created. One will have the location and date/time but no photo, and then the second one will have the photo but no location or date/time.
Super frustrating. I noticed it first a few days ago - maybe a week at most. It doesn’t happen to every observation (seems more like to be the first or second ones I make in a sequence) but it is a pain to delete the bad observations and add in the missing information (either photos or location/date/time) to get a good observation out of it.
I’m using Android version 1.25.7 (522) running on a Pixel 2. It a somewhat older phone so I thought that that was the problem at first.


1 Like

They’ve had this bug of “false duplicates” for a while on the Android app. It seems to happen when the upload process gets interrupted, for example when you have poor cell reception. As a workaround, you can get the extra copies of the observation to disappear by logging out of the app and then logging back in.

I’ve been using the app for years, never had this particular issue. I had full wifi and cell signal at the time as well.

Logging out and back in did not resolve the issue. I haven’t had it reproduce yet, so I mainly posted to see if others are having the same issue, and in case it does crop up again.

1 Like

Seems to be the same problem and timing as my issue. Same OS and similar app version. I hadn’t noted whether there was any hang-up at the adding photos step, I added from my ‘gallery’ I believe, but I’ll double check if it was from ‘library’, since I might have also switched settings on that before the error cropped up.

When this happens to me, I’m not trying to upload observations. The only use of a connection would be to get a location for the observation. Something goes wrong when making the observation, specifically when taking the photo.

The same issue has recurred as of two days ago while duplicating an observation for something growing on a barnacle shell. I have URLs here:

original observation:
duplicated observation:
‘extra’ duplicated observation:

Side note–I haven’t been able to load screenshots to the forums via Firefox in about a week, but I might report that separately.