Android app not reading picture location data

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android (13, build number TP1A.221005.002)

App version number, if a mobile app issue (shown under Settings or About): 1.28.8 (561)

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): Android app is no longer reading location data from photos. I have confirmed that the photos are saving with locations. I tried an uninstall/reinstall to no avail. I do notice that the select photos screen is different. I’m not sure if this is an Android change or an iNat change. I see that my phone hasn’t done a security update since 10/5/22 and a sytem update since 11/1/22.

Step 1: Click new observation> Choose image

Step 2: Select photo(s) and click Add


Here is a screenshot of what this new choose image screen looks like. I didn’t start seeing this version until yesterday


Interesting. Which device are you using?

I have the same issue. Samsung S22.


I am using a Google Pixel 4 XL

1 Like

Which version of Android OS is your device running?

Same issue. Xiaomi 11T

1 Like

Version 13

1 Like

I actually found a workaround for the issue.

If you click the 3 dots next to the Photos | Albums buttons in my second screenshot, then click Browse, it will bring you to the old, familiar photo selection screen. If you choose images from here, it will have the location attached like normal.

Hopefully a full fix can be found, but this is a pretty simple workaround in the meantime


It seems to be related to the new Android 13 photo picker and how it retrieves location data. That’s about as far as my technical knowledge allows me to research this.

Here’s a couple relevant links I found:


OK, I can actually replicate this on my Pixel 3A with whatever new system update they added to Android 12, and I made a GitHub issue for our developer here:

@ncb1221 thanks so much for sleuthing some of this. The “Browse” workaround worked for me, and I was also able to share photos from my Files to iNat and have the location included.


Just realized, it seems to work now again for me. Thanks!

If anyone is affected by this and hasn’t tried the fix @ncb1221 detailed above: we believe we have a fix for this issue in a beta version, and would love to see if anyone can test it. I can’t test it out on my Android device (even after a factory reset) once I made the fix.


I honestly thought a fix had already been implemented. A week or 2 after this my app reverted to the old picture selector and I had no more issues

1 Like

I’ve been having this issue (no latitude/longitude imported from photo into iNaturalist) both when I select photos from within iNaturalist, and when I go to the Google Photos app on my Pixel 6A phone (Android 13) and “share external” to iNaturalist. I have not tried the fix @ncb1221 suggested yet, as I just found this thread. Perhaps I could test the fix @tiwane mentions above if that’s still useful.

1 Like

Great! Can you please email I can go through instructions with you there.

Hi tiwane. Apologies for missing this earlier. It turns out my problem was elsewhere – my camera application was not recording location information at all, so the iNaturalist app could not have used the location metadata that didn’t exist. When I found the place in settings to turn on location recording for my photos, the location features in iNaturalist began working straight away. So I don’t think I can help debug since I’m not reproducing the problem at this point.
FYI I am running v. 1.28.10 (563) of iNaturalist on a Google Pixel 6A with Android 13.

1 Like

Interesting! I’d noticed some photos in my Samsung’s gallery were missing location data…but not all of them. It seems to go back & forth between which ones are affected, so I’m wondering if I took them in a tower dead/blind spot.

Sometimes if you open your camera and immediately take a photo, the camera app doesn’t have time to get your location. If you keep a GPS tracker going in the background, though, that should eliminate the issue as your device is already getting GPS data on a constant basis.

1 Like

I think some of them happened in the same location, and that was why I assumed a blind spot, but that makes a lot of sense as well. Thanks, Tony!

1 Like