Atlas / Place boundary issues - wiki

While trying to drawn down the backlog of flagged atlases and create some new ones, I’ve run across some specific boundary-related inaccuracies:

  • The Bonin Islands (or Ogasawara Islands) don’t appear to be included in the atlas polygons at all
  • The Volcano Islands to their south are included in Shikoku. Both island chains are part of Tokyo prefecture.
  • The polygon for Isla Tortuga, east of Baja California, is located in the wrong place, as is that for Isla San Pedro Martir to the north.
  • Akimiski Island is included as part of Kenora, Ontario, but should be part of Qikiqtaaluk, Nunavut
  • Fatu Hiva and Motane or Moho Tani lack boundaries; these islands are part of the Îles Marquises, French Polynesia, and immediately adjacent to the mapped islands.
  • The Prince Edward Islands (including Marion Island), part of South Africa, are missing from the map.

Further atlas-related glitch: when selecting the State of Santa Caterina, in Brazil, Santa Caterina, in the State of Amazonas, is automatically selected at the same time.


Can you please provide screenshots and URLs?

Open any atlas for any taxon, go to Brazil, explode it, click on the State of Santa Catarina. Both places are now selected.

Any thoughts on the Santa Catarina issue?

@tiwane I was just editing another atlas with the Santa Catarina issue…

Thanks so much for doing all the hard work to diagnose this issue and provide fixed geometries, Jane. I just uploaded them and they look great!

update: Actually - looking at this again, I think we need an updated Amazonas too without the hole left from Itapirangas, is that correct @jwidness?

Oops, good catch. I just sent it over.
Thanks for the help!

worked great - thanks!

Hm, the boundaries look fine on each place page, but I’m running into issues with atlases. For example, I’m trying to add the Itapiranga in Amazonas to the atlas for Bradypus tridactylus, but I can’t select the place. Just to try it out, I also exploded Santa Catarina and tried to add the Itapiranga there, but no luck either.

should be fixed now

I can select the Itapiranga in Amazonas, but it’s still not working for the Itapiranga in Santa Catarina.

Are the atlas shapes stored separately from the boundaries for the places? That is, did correcting the shape of Amazonas here correct the atlas shape, or was that a separate step?

The inability to clicking Itapiranga in Santa Catarina seems to have something to do with the UI on the Altas page but not the underlying data.

The atlases just use standard places. So if you change the standard place boundaries the atlases change. similarly if you add/remove a species to a standard place default checklist the atlases change. So if you wanted, you could add 3-toed sloth to the Itapiranga in Santa Catarina default checklist and that place would show up green, even though the UI won’t let you click on it…

1 Like

@choess do you think you could convert your original post to a wiki? I’d like to add other issues and that might be a nice way to keep them all together.

I don’t seem to have the trust level to do that, yet. I’d add to this thread for the time being.

@bouteloua kindly upgraded it for me–I’ve removed the Channel Islands, which seem fixed, so go ahead and add your issues.