Can't see certain observations by other people

Platform: ios

App version number: 2.8.7

Description of problem :
Whenever I introduce someone to Inat and help them set up their account, (a relative, friend, etc…) when I search their username on my phone in explore, I can see the first one or two of their observations and the next two or three I can never find! after a while I can see other ones they posted, but I can never see the third through fifth. I can see them on my computer, but not on the app. is anyone else experiencing this?


Can you please share a screenshot of what you’re seeing?

I am not 100% sure if I can… it is only on my phone, and i’m not sure how to transfer a photo from my phone to my computer…


You can email the screenshot to yourself, use something like Dropbox or Google Drive, or just add the Discourse app to your phone and post from that.

1 Like

I will try to do that. thank you.


here it is. if you search the profile on the computer, he has at least two or three other observations before that in Louisiana.


And they’re located in the map area you have selected? It looks liek your searching in a map area and not the state of Louisiana.

1 Like

I set it to Louisiana and it still didn’t show the observations…


I think the issue (at least in this case) is that some of randy’s observations have enormous accuracy circles, like this chimney swift observation.

The radius of the accuracy circle here is 1000km:

If Randy edited the locations of some of these observations to be more accurate/precise I bet they would show up in this search.


this is another person who only has a few observations. if I search the name, it only comes up with three observations, even though the person has six. It does the same thing for at least one other person.


Looks like it’s excluding their Casual observations.


this is another one that is missing two random observations. one was a camel seen in Africa, and another was a swan seen in Boston. it even says that the person has 19 observations, but it only shows 17…

1 Like

Thank you so much for taking the time to help me figure this out!

1 Like

I was recently looking at some of my observations of snakes with the explore feature, and two of them were missing! I am thoroughly confused…

a couple of things first:

  1. the more information you can provide in terms of screenshots of exactly what you’re seeing on your device, what kind of device you’re using, what filter parameters you’re using, and exactly which observations are missing, the more easily someone will be able to help you. for each case you bring up, you’ll want to provide separate information for each case. if you provide very little information about any case, you’re reducing the chances that someone will be able to help you, or else you’re making someone else jump through lots of hoops to be able to help you.
  2. if the iOS app is anything like the Android app, by default, the app Explore page will restrict the results to a given map area (which the website will not do by default). for example, if you look at the screenshot that you posted above, you’ll see that in the light gray section, it says that it’s restricting results to a specific map area. i’m guessing that the app probably applied that map area restriction by default.

now on to the 2 problems quoted above… i’m guessing both of these are related to the default restriction of results to a map area. try clearing out the map area selection to do a global search instead, and see if that brings in all the observations you’re expecting to see. (it’s also possible that, as tiwane noted above, large accuracy values reducing the likelihood that a particular observation will fall into a given map area, but that should be moot if you do a global search.)

that said, i don’t think any of the 4 issues you’ve brought up in this thread are actual bugs. it may be time to close this bug request. if you would like to discuss “top things i wish i had known about using the iOS app”, that might be worth doing in a new thread in the General section. or if you think it might be better to have the app search globally instead of within a restricted area by default (to match what the website does), you could bring that up in a thread in the General section or maybe as a Feature Request.

so I tried it without the “restricted to current map area” and there was still one missing. at first there was a northern cottonmouth that was also missing but I realized that it’s geoprivacy was set to private, so I fixed that and it appeared :). there was a diamondback watersnake that is also missing. as far as I can tell, there is nothing wrong with that observation… I am using an iPhone 10, but it has done the same for other devices…

i can’t tell by your last post exactly whether you’re saying you still see a problem with the snakes or not. i don’t have the iOS app, but on Android, things look fine:

note the parameters i used were:

  • user id = a_awesome
  • taxon = snakes
  • search area = global
  • include research grade = true
  • include needs id = true

note that it returns 42 records, which matches what the website returns. i’ve circled the cottonmouth ( and diamondback watersnake ( observations which i believe are the ones that could have been problematic.

i believe these could have been problematic because prior to your last post, they both had mappable flag = false. since you’ve change the cottonmouth observation to something other than private geoprivacy, that observation is now mappable = true. however, the diamondback watersnake observation is still mappable = false.

  "total_results": 1,
  "page": 1,
  "per_page": 30,
  "results": [
      "id": 20561657

so if you’re saying that in the iOS app, the diamondback watersnake observation is still not showing up in the Explore page, even when searching globally, then there is probably an issue with the iOS app – in which case, i’m guessing it could be excluding observations where mappable = false, even when search area is global.

but as i said before, i can’t tell for sure based on your last post whether or not you still see a problem. if the iOS app displays the info somewhere, it would be helpful to see screenshots of the number of records returned, the last 6 (the earliest 6) observations returned in the set (including the cottonmouth observation), the parameters that have been applied in the search, etc.

it’s not clear to me why the diamondback watersnake observation would have mappable flag = false. normally, this would only be set to false on non-private observations only if the accuracy value is huge. so you could try adjusting the accuracy value to see if that changes the flag. (if it does, the link above should return total_results = 0.)

1 Like

Looks like the accuracy radius (of the unobscured point) is 5 meters. Interestingly it is listed as mappable = true here:

1 Like

i think the observation must have been changed after my last post, since the link in that post now returns no records.

1 Like