Creative Common licensed photos not loading (AT&T)

I am still experiencing the problem. I will try to get a hold of ATT. Thanks!

1 Like

Same problem (only some images visible) with AT&T Fiber in Albany, Georgia (southwest Georgia).
When I switch to Verizon Wireless, all images visible as normal on iPhone and iPad.
Using Safari on a Mac Studio, iPhone 12 and iPad 8th Gen.
The problem began on or about 8/22/2022; nothing had changed on my end.
I have not contacted AT&T yet.

ISP ATT fiber
Kansas City area
problem remains

ISP AT&T fiber
Austin, Texas
Problem remains

  • All devices affected on home wifi (iPhone, iPad, and 2017 MacBook Pros).
  • Problem occurs with every browser tested (Chrome, Safari, and Firefox).
  • Only photos hosted on AWS are affected.
  • No problem when I turn wifi off (on device) and use AT&T cellular connection.
    • No problem on wifi elsewhere. Although I did not think to check their ISP, if I recall correctly they use Spectrum.
  • I have AT&T Smart Home Manager and AT&T Active Armor, but the problem arose without my having made any changes to their settings. IIRC, the problem began Friday, 8/19/2022. And it began while I was working—everything was fine on one pass through the Identify workflow, and when I changed the state (the location of the observations I was reviewing), suddenly 20 to 25 out of 30 observations on any given page had broken images. I went back to look at pages I had previously reviewed, and they looked fine. Then I cleared the cache and reloaded the pages, and I found the same problem wth them.

After trying all sorts of things—gateway reset, restart devices, stand on head, let dog operate computer—I thought to check the sources of all images. Those hosted on iNaturalist are fine; those hosted on s3.amazonwebservices are broken.

If I figure out an answer, I’ll let you know. Google fiber just arrived in my neighborhood, so I might fix it that way. :wink:

1 Like

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform ---------Website

App version number---------N/A

Browser---------Firefox (tried Brave and Chrome too)

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing

Including URL for latest upload

URL for Dashboard (?), Homepage (?)

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Just go to my Dashboard, Observations. You will probably see the photos but (see screenshots) I do not.

Step 2: I read former topic someone submitted: › im-getting-no-pics”
which looked like the same problem. At the very end of the thread someone sat that his address seemed to be blocked by iNaturalist and they removed the block. I don’t remember how to see my ISP. I am on my AT&T Fiber optic connection which is fast. At my appartment I have comcast which is also fast. This used to work from here. I don’t remember if I used it at my apartment.

I can still see all my Flickr Photos, and all my Bugguide photos so the problem is limited to this site. I can stilll do YouTube and Netflix for that matter.

I’ve turned all of my add on blockers off. Firefox is Vers 104.0 (64-bit windows).

Oh! I have firefox’s tracking protection set to STRICT. I guess that could be a problem. I will change it to standard and see if that helps.

Step 3:

Changing to Standard Tracking protection did not help!

-Arther Macmillan

Hi Arthur - sorry you’re running into this issue. Looks like this is a known problem with AT&T right now. There are some steps here that may help you:

@bouteloua that link does not delineate the steps, and the interface is anything but intuitive, so screenshots are essential. Here are the steps with screenshots:

  1. On your smart phone, open SmartHomeManager (SHM). It will test your network for a while and then display the home screen, perhaps like this:

  2. Notice the icon I circled in red at upper right, the one that looks to me like it’s for starting a chat? It isn’t. Click it. When you do, SHM will take you to the Message center, where it displays all the messages you have received from SmartHomeManager or its companion app, AT&T ActiveArmor:

  3. Notice all the “Website Blocked” messages? You’ve probably been getting messages on your smart phone worded just as cryptically as those. Click one of the messages to get more information. Here’s what the details message looks like, with the first message magnified to make it easier to read:

  4. The other boxed items are the URL that was blocked—in this case, —and a button reading Allow Access. Click the button, and when you get the inevitable “Are you sure?” message, answer with a yes. The details screen will update, replacing the Allow Access button with a message that begins This website has been allowed:

  5. The problem is now solved. At least it was for me. Something that is interesting to me is that when I fixed the problem I did it through a message that did not mention my MBP (MacBook Pro) because it was about an instance that occurred on Safari iOS—that is, on my iPhone. I went through the steps again as shown above because I thought that surely I would have to approve the site for each device. Nope. Even though it took me through the steps shown above, the problem was already fixed on my MBP. I had already opened iNaturalist on it to confirm that going through the process device by device was essential, but all photos were already displaying properly on it.

  6. OK, back to that Access Allowed message I showed in step 4: at the bottom, Security exceptions is a link. Click it. SHM will take you to this screen:

    I wish I had captured this list before. It had told me that no exceptions had been added. I had already figured that out.

Last night, I got to the Exceptions screen this way (no screenshots, because it’s easy to follow, for one thing, and it doesn’t get the job done, for another):

  1. On the SHM home screen, I clicked Settings (the gear icon at lower right).
  2. On the Settings screen, I clicked AT&T ActiveArmor.
  3. On the AT&T ActiveArmor screen, I clicked Security exceptions.
  4. Because I had not yet added any exceptions, the Security exceptions screen gave me a message to that effect—and no explanation of how to do that, and no link to follow to either find that information or get it done. As in the image shown in step 6 above, the only way out of that screen is the arrow at top right pointing back. And that’s a “Back” button, not a link. In other words, when reached as described in this series of steps, it takes you back to the AT&T ActiveArmor screen, where there is no way to add an exception or even get more information—but when reached as described in the first set of steps above, it takes you back to the Message center, which you had already stumbled upon as the way to get it done. Helpful, right?

@arthurmacmillan, @roy_cohutta, @tatejack, and anyone else I might have missed, I hope those steps work for you. So far I have been able to see every photo that had been blocked last night.

AT&T: We make the easy impossible.


Thanks for the detailed instructions!

I am here to upload a similar set of images.
This works!


Thank you. iNat is down for maintenance at the moment, but it looks like that fixed the site block by AT&T.


Is it possible that the device you are using has some form of blocker, such as iBoss? I know some of those pre-installed blockers can block photos sometimes. Especially if it’s a school or work-issued device.

@yayemaster, in this case it was device-independent. Our ISP, AT&T, was doing the blocking, and we had to use two specific AT&T apps in a specific sequence of steps to whitelist the website in question. The apps must adjust our gateway settings, because once it was whitelisted from any device it was whitelisted for all devices using my wifi.


Shouldn’t this one be marked as fixed? I gave a thorough explanation of the solution, and bgrhughes provided the short, scroll-free version.

i agree, but that power lies with the original poster, or, alternatively, moderators and staff.

1 Like

I guess that would be @joseph103 (who might not realize he’s the original poster), @tiwane, or @bouteloua.

I can’t speak for staff’s interpretation of resolved, but ideally it wouldn’t require people to go thru those steps and AT&T would fix it for everyone. I guess it’s not a problem on iNat’s end, but a lot of people are running into the issue and resolving/closing might make it seem like the issue is actually “fixed”.

But this isn’t a bug for either one:

  • iNat’s website is working as designed.
  • AT&T’s algorithm sees something suspicious in that activity—perhaps the number of redirects involved in getting a photo from AWS; perhaps the many levels of subdomains on AWS; perhaps something else.
  • From AT&T’s standpoint, the system is working as designed. The user must decide whether AWS is trustworthy in spite of that suspicious behavior.
  • From the standpoint of the customers of AT&T, the problem is an app that produces cryptic status messages that have only the weakest of connections to the solution to their problem. (Even the more tech savvy among us are stymied because the most straightforward way to deal with it—the path that definitely should work—is a dead end.)

In this thread we have two crystal-clear presentations of the answer—better support than AT&T itself is providing on this topic. Here’s what I think we need to do:

  1. Retitle the thread, now that we know the real problem: Creative Commons–licensed photos not loading on AT&T wifi
  2. Edit the original post to point to the answers.
  3. Close the topic.

Otherwise, we are liable to get all kinds of new comments offering well-intended advice that is actually just another false lead—and anyone who is still having this problem and doesn’t realize that a solution has been worked out might try following the latest tip rather than dig deep into what must seem to be a pile of other things that didn’t work.

I kept this open mostly as a place for people to discuss the problem, even though yes, it’s technically not a bug on iNat’s end, and also with the hope that someone would report AT&T had fixed it. But I agree that at this point it’s probably not worth keeping open.