Creative Common licensed photos not loading (AT&T)

I have this exact same issue since yesterday and none of the images I have uploaded are showing up. As soon as I upload them, they are replaced by a broken image link icon. I am using Chrome, but have also tested this on Firefox and on Safari on my iPad. None of them show any of my images. It is not an extension issue. I have no extensions on Safari. It is not a poor internet connection. I have a rock solid 1Gb fiber connection. The problem appears to be at your end.

Please advise.

1 Like

one thing that’s common among folks who’ve mentioned it is that they’re using Apple products. has anyone seen any problems using a Windows machine or a Linux machine?

It has nothing to do with Apple products. I have the exact same symptoms with Chrome and Firefox on Windows. The point is that it is not a browser issue. The problem is 100% reproducible on all browsers and all OS’s. Here is my screenshot showing the errors in Chrome.

the problem shown in your screenshot below (no photos on the observation detail screen) looks different from the problems others are reporting in this thread (errors loading photos in the upload screen). in your case, it looks like you probably have an extension on your browser that’s blocking content from Amazon. iNat stores some of its photos on Amazon’s cloud. so i would try either whitelisting the Amazon server shown in your screenshot, or else disable your extensions altogether.

i realized you’re the one who said that you’re using an iPad, and you noted:

if this is the case, then there may be something that your router or ISP is doing to prevent you from accessing the Amazon server. check your router settings or call your ISP. it could be something as simple as changing your DNS settings.

you can also try using your device(s) on another connection or through a VPN, and see if that changes anything.


There is no extension blocking anything in my browser. I already reported that the condition also exists in Safari which has no extentions. But just for fun I disabled all extensions in both Firefox and Chrome and the problem still exists. Here is a screen shot from Chrome in safe mode. You are right, the problem is that Amazon web services is not functioning correctly.

not sure if you saw my edit from above. so i’ll repeat it here:


Okay. Disabled WiFi on my phone and connected using a straight cellular data connection. Bingo, the photos are back. So there is likely something wrong with AT&T routing to aws.

1 Like

As of 9:10pm tonight the problem appears to have been resolved by AT&T. All photos are displaying normally.

1 Like

I’m having the same issue. I haven’t tried uploading anything, but I can’t view most already-uploaded images. I’m using AT&T Fiber, and it’s happening on both my PC and phone (connected to Wifi.) If I turn off Wifi, pictures load correctly over my cell network (Verizon.) I tried changing the DNS on my router from the setting to obtain from ISP to Cloudflare, and it didn’t help. So I don’t know that the issue is DNS.

I moved the above posts to a separate topic as they were not related to

@kev317 are you still experiencing this issue? There isn’t anything we can do about a problem with an ISP, for what it’s worth.

Reposting from the old thread.
I first experienced the problem yesterday (8/23). I emailed to iNat and Tony pointed me to this forum. I am on ATT fiber. I tried two different Windows machines, an android tablet, and my mobile phone. All experienced the problem. With wifi off on my phone (Verizon) I got images. I have reset my gateway and local router with no improvement. Occasionally a few images load but 90% of the time nothing. Is there any info coming from ATT?
Additional info:
No other web functions are affected.
Current wifi performance: Upload 156Mbps, Download 84.6Mbps, Ping 15ms

Some observations and questions for the Forum.

From forum comments it appears:

  • The problem is not device specific. Windows, Android and Apple users report the issue.
  • The problem is not browser specific. The problem is experience with Chrome, Firefox, Safari, Duck Duck Go, etc.
  • The problem began on its own, no user configuration changes tied to the problem start.

Some info from users could help identify the path to correct the problem:

  • Who is your ISP? (Mine is ATT fiber)
  • Where are you located? (I am in Central California, Monterey Bay area)
  • When did you first experience the problem? (Mine started 8/22, first noticed early afternoon)
  • Has your problem been resolved? How?

I am trying to determine where to push for a fix. If it correlates with a specific ISP or location that is a clue. If it is an AWS / Creative Commons thing we may need iNaturalist assistance. As a user I wouldn’t know where to start with that relationship.

1 Like

joseph 103, Can you provide more info on your resolution. Did ATT fix it? Who did you work with at ATT? Did you have to do something on your end? Where are you located?

FWIW, something similar happened in Mexico a few weeks ago:

Via help@inat: an AT&T user was able to get photos loading again by using the AT&T Smart Home Manager app and allowing access to

For some reason AT&T doesn’t like it. We’ve run it through multiple security checks and it’s passed them all, and the SSL security certificate for it is valid. So I suspect it’s a mistake on AT&T’s end.

1 Like

I just went through a troubleshooting session with ATT. A background function “ATT Active Armor” appears to be a factor. Turning off the function brought back some images but not all. Home page images were back. The first page of Observations had images but not later pages. If I access the page for a specific observation there is no image. Also, Edit Observations does not display images. I am expecting a call back from an escalated tech. BTW, I could not use the Smart Home Manager work around because my Android tablet is not compatible.

1 Like

I saw that post from Mexico. Tried changing from Spectrum’s DNS to Google’s and also OpenDNS. Neither made a difference. Edit: Oops wrong thread. That’s what happens when you have too many bug reports open at the same time…

I am still experiencing the problem. I will try to get a hold of ATT. Thanks!

1 Like

Same problem (only some images visible) with AT&T Fiber in Albany, Georgia (southwest Georgia).
When I switch to Verizon Wireless, all images visible as normal on iPhone and iPad.
Using Safari on a Mac Studio, iPhone 12 and iPad 8th Gen.
The problem began on or about 8/22/2022; nothing had changed on my end.
I have not contacted AT&T yet.

ISP ATT fiber
Kansas City area
problem remains