Uploading a photo fails every time

All of a sudden I can’t upload any photos. The photos appear in the upload window for a few seconds, then they are replaced with the “upload failed” icon. I tried it with different photos that had been previously uploaded. I logged in and out of iNat. I restarted my machine. Can’t figure it out. Is there a system problem right now.


Can you please share a screenshot of what you’re seeing, as well as which browser and operating system you’re using? Here are instructions for how to take a screenshot on several types of devices: https://www.take-a-screenshot.org

1 Like

Happening this evening, for at least the past 90 minutes. Whether I drag and drop photos, or select them, the images appear briefly, then get replaced.

The same error occurs with both Chrome (Version 78.0.3904.97 (Official Build) (64-bit)) and Firefox (70.0.1 64-bit). (The screenshot is from Chrome.)

1 Like

CIRCUMVENTION: I was able to create the Observation without any photos, then edit it to add the photos I wanted.

The photos came from the same location on my hard drive that I tried using to create the Observation which produced the error above.


Not ideal, but it allows me to upload continue uploading Observations from my laptop.

1 Like

Looks like I’m not the only one it’s happening to. This from a few minutes ago. It started about 3 hours ago. Hope this works.

1 Like

That sounds like a time consuming process.

I’ve had similar problems in the past when connection speeds drop.


Photo file is too big for upload speed to sustain?

Nope, it’s happening to me too and the photos are pretty small compared to some that I upload often


Ok, it’s still happening this morning. I have 3 options for wifi, so I tried all three, just in case that might be the problem. They are all fast. The files are small. Because it is happening to others, it appears to be an iNat system problem. As @xris said, the workaround is to upload the observation without a photo, then edit and add the photo.

Can you please send a photo or two to help@inaturalist.org so we can take a look?

ok, but it doesn’t matter which photos I use. I’ve tried several that have been uploaded before, all sizes.

It doesn’t matter which photo I use. These have all been uploaded recently with no problem, but nothing will upload yesterday or today.

But I did send the email


@tiwane: You can see the photos in the Observations I edited to add them after the initial upload fails.

I used my circumvention with all my observations since the problem started over 24 hours ago, for example:


The images are not the problem, since we can add them to the Observation after creating it. Also, the images show briefly before being replaced by the “error” icon. So something is going wrong in processing the images, but only on initial upload.

Another clue: SOME of the image metadata is applied to the Observation on initial creation, but not all. The Description/Caption, and Date/Time of the photos are applied to the Observation, even though the images are not. But TAGS on the images are lost. (I don’t have any examples of photos with Geotagging, so I don’t know if that is preserved or lost. I suspect it will also be lost.)

The problem is not bandwidth, since multiple people are reporting this. Myself, I’ve had the same problem at different times of day and night, when both network traffic and demand on the service would vary. There is no change in the symptoms.


iNat resizes/strips some info from photos when you upload them, so the developers generally need the original photos to diagnose certain issues.

1 Like

Sorry–I waffled as to whether I should specify via email (help@inaturalist.org) or a link to download the actual original photo…this forum also resizes/strips photos.

How do they know which problem it’s about? How do I identify the random photo I’m sending them is for this Bug Report?

I’m also a developer. I appreciate the difficulty of reproducing a bug.

I’ve uploaded hundreds of Observations in this way. This is a recent change in behavior. I would be looking at what changed yesterday - wen the first bug report came in - or prior, that could affect this.

I would just include a link back to this report.