Final submit step fails with *JPG*s created with software **Nikon NX studio**

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Final submit step fails with JPGs created with software Nikon NX studio .

When I try to upload a jpg that was edited(from RAW file) from Nikon NX studio.
the Ai suggestions work fine,
the preview image works fine.
I get this error only when I use the final submit.

If I use another software to “resave” the JPG, it will submit fine.

I have tried an updated version of the NX studio, but it still errors when submitting.

1 Like

you should probably send one of your images to to see if one of the staff can reproduce what you’re seeing. (alternatively, you could save one of your images to cloud storage or something like that, and point to a publicly accessible version of it in a forum post.)

1 Like

I can get it to work adjusting the JPG settings.
I remove XMP.IPTC information, and I added ICC color profile.

not sure which setting helped.

I’d be happyt o take a look at a photo if you send one to Best to do it via Dropbox, Google Drive, or a similar method. Email services often strip metadata.

Thanks for sending the photo. This is the observation, correct? You might want to change your forum username to match your iNat one, so it’s easier for people to know who you are on iNat.

I was able to upload the photo just fine in both Firefox and Chrome, and I tried adding an ID and location once, and also tried it without adding an ID or location.

  • are you certain you sent me the photo that causes the issue, and not a version that you fixed?

  • are you dragging the photo directly from Nikon NX Studio to the upload page in your browser? Or are you exporting the photo as a jpeg from NX Studio and then uploading that exported file into the browser?

@tiwane Thanks,
yup that’s the observation.

weird it’s working now.
I just uploaded a test to the middle of the ocean.( deleted it)

I tried many times over the past few days, and multiple images were not getting past the final submit step. Only today I noticed which ones worked.
I also tried multiple computers, since I tried to upload one at work and it didn’t submit.

I am using chrome. windows 10.
yeah, it’s the same file. I just checked.

my process was → upload button → choose files button → use system dialog

I don’t drag and drop anything.

I export a JPG out of NX studio to a folder. then manually select it from the browser.

I’ll let you know if I find more problems files.

1 Like

Generally this is an issue with the editing software, not the iNat software.

As a non-iNat example; when I make a PDF in Photoshop I often have to run it through Acrobat and do a ‘save as PDF’ to ensure that it opens in other software properly. Both products by Adobe are supposed to make the same kind of PDF and I have the compatibility setting’s set the same, but the PDFs are different in some crucial way, and other software sometimes has issues with the Photoshop reated one, even though both are saved as PDFs.

I agree, this is why I brought up the issue.

If someone new trying to contribute, is likely to be turned away if their posts are not submitting.
They would be very unlikely to try and debug any issues.

which adds to the strangeness when the other image features(ai ID suggestions) work, but submitting does not.