Photos failing to be saved on upload

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Mac OS 12.2.1

Browser, if a website issue (Firefox, Chrome, etc) : Brave

URLs (aka web addresses) of any relevant observations or pages:
https://www.inaturalist.org/observations/107385929

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I keep trying to upload the photo for my first observation, and while I see the icon suggesting the upload is in progress, it keeps giving me the error message, “Failed to save record. Please try again later.” This happens both when I select a file from my computer, and when I drag-and-drop the photo.

Is this happening for all images, or just one image? I see some errors saying the image could not be identified, which leads me to believe this particular image has an issue. Could you perhaps attach it to this thread, so we might try downloading it to replicate the problem? I’d recommend trying other images to see how isolated the problem is.

Hmmm. With the same image, I get “Sorry but your upload failed.” when attempting to upload to the forum. Is there a maximum size to consider?

I believe the maximum upload size for the iNaturalist websites and apps is 20MB, though I see your file is quite a bit less than that and I do see that the failure happened when trying to process the image, not on the upload. I suspect there’s some problem with the image itself - some corruption, and incorrect encoding, or something else. Can you view it on your computer or phone? I’d try re-exporting it, or trying to save a copy, maybe some minor crop and saving it again, in an attempt to get a new copy that doesn’t have the same problems.

2 Likes

Well, I tried again, and this time it worked. So, all is well. Thanks.

1 Like