Having error uploading observations on website

Platform: Website

Browser: Chrome

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations/upload

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): Trying to upload observations but get a red error exclamation mark instead of my photo.

Step 1: I upload photos from an SD card.

Step 2: On the website, it normally goes smoothly but lately it has been showing this instead of photo. I have tried to upload it with the error but it says it is missing the photo.

I have had this issue in the past but it has gone away quickly, have been having this error for almost a week and can’t upload my observations. Please help!

1 Like

In my experience it was always connected with bad Internet connection, but if you have no problems like that, it should be something else.

1 Like

Can you please send one or two of those photos to help@inaturalist.org?

Can you please open up your browser’s console (see instructions) when you see these errors and take a screenshot that includes the console? The console records errors that we can look at.

1 Like

there’s a thread where others discuss similar things: https://forum.inaturalist.org/t/pictures-upload-failing-when-creating-a-new-observation-via-web-browser/34497.

the last time something like this was brought up in that thread, it seems like the problem could be avoided by connecting directly to the router with a cable instead of using wifi.


Thanks, y’all
It seems to be getting better(better internet?) only a couple of the observations are having the error.
@tiwane I sent you a screenshot of it.
I guess I just have bad internet because I tried to do it in several places on several different internet routers.

*Edit: Spoke too soon, I will try plugging directly into it with a cable tonight


Thanks for sending the photos and the screenshots. I was able to upload the photos fine. We’re pretty sure this is a local issue, with an internet service provider, router, or something along those lines, and not something iNat has any control over.

1 Like