How to stop mobile app opening clicking links in mobile browser

Suddenly when viewing and using the website on my mobile browser, every link I click on tries to open the mobile app and go to the content there.

How do I stop this?

2 Likes

Maybe ‘‘Clear an app’s default settings’’

https://support.google.com/nexus/answer/6271667?hl=nl

https://support.google.com/nexus/answer/6271667?hl=en

Mine suddenly started doing the same- I’d be browsing iNat on Chrome and any time I’d click a link it would pull up “select which app you want to open this link” and offer either the iNat app (no thanks) or Samsung Internet (gross)- I want links I click in chrome to open in chrome! No idea why that started happening out of the blue.

As a workaround, tap-hold then select “open link in a new tab”.

I followed the directions at optilete’s link to clear defaults for samsung internet and the next time I clicked a link in iNat it gave me a larger list of apps to pick, so I selected Chrome and that seems to have fixed the problem. I imagine clearing defaults for the iNat app would enable the same process and result.

Hm, in Chrome on Android, I open the iNat mobile website dashboard and click on a link, it asks if I want to open in the mobile app or in Chrome, and I select Chrome.

But it resets every day and asks me again. Pretty sure no settings/cookies are being reset/deleted each day, because I’m still logged into most websites in the browser.

I went into my iNat app settings and changed “Open supported links” from “Ask every time” to “Don’t open in this app”. I would have thought selecting “Always” when prompted would update this automatically. Hopefully this works?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.