Phone app doesn't open direct link to external site images (imgur for example)

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): 1.21.7

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Click the link at the post above using phone app and nothing will happen;

Not sure if this is a issue with imgur images only, but it seems the phone app won’t start a Internet Intent when clicking a link that directs to a image hosted on third party websites.

I checked it everywhere and the image loads for me:

  • Chrome browser on Windows
  • iPhone app - opens in Safari
  • Android app - opens in Chrome

Note that the image may load in different apps depending on configuration and the problem might be in them. For example there’s an app for Imgur for Android that may open those URLs (if installed and chosen as handler).

Strange, I tried it for a second time on the Android app and this time it didn’t work. It worked the first time when I chose Chrome as the handler for those URLs…

I’m beginning to see a pattern on Android app + Chrome: only the first click on a URL inside a given observation works. Any subsequent clicks don’t work (no action is taken) no matter whether on the same link or another. When I change to a different observation - again only the first click works. If I return to a previous observation - again the first click works.