Some images not uploading when using upload feature

web
#1

This report applies to the iNaturalist web app on

  • chrome (Version 72.0.3626.121 (Official Build) (64-bit))
  • macOS 10.14

When I upload a group of observations (>10, < 30) I often find that one or more of the observations becomes “corrupted”. Specifically, the observation seems to become disconnected from the photo. As I add data to the observations, in the upload screen more images become corrupted in this way. If I finally go ahead and upload the observations. A record is created with no image. If I try to add the image to the observation later it doesn’t stick. The image uploads but then doesn’t display.

The uploaded observations end up like this

https://www.inaturalist.org/observations/21568381
https://www.inaturalist.org/observations/19185829

If I try to add an image to these observations several days later it still doesn’t stick! the image appears to upload successfully but then doesn’t display.

I have tried deleting the observation and starting again but once an image becomes tainted like this I don’t seem to be able to get it to upload at all.

1 Like

#2

this could be a sign that you’re using a slow or flaky internet connection. what kind of connection are you using?

1 Like

#3

48%20PM

0 Likes

#4

I have tried three times to add the same image to the first observation mentioned in the original report. The image appears to upload but then doesn’t display. I don’t think this is anything to do with internet stability.

0 Likes

#5

ok. i believe you. i’ve never encountered the problem except when i was loading a bunch of photos on a flaky connection that hiccupped. but if you’ve tried to load the same thing several times, and it’s not working, then i’m not sure.

one more thing you might try is to load a photo that you were able to successfully load into an observation which you were not able to successfully load a photo, just to see if you can narrow down whether it’s more likely something about the specific photo or the observation.

other than that, i have nothing else i can offer, and i’ll defer to iNat staff or others with more knowledge at this point.

0 Likes

#6

Ok so I tired some experiments

  1. Load the image that should go with the observation - no joy- image did not load
  2. Load an image from another observation that did not load - no joy - image did not load
  3. load a test image of a stuffed toy that has never be loaded before - it works!

SO… either

  1. There is something randomly wrong with some of the images i am loading. Weird because they all came from the same camera.
  2. I naturalist fails to process some images AND then remembers them and fails to process them if you try to load them again. Weird? Do you guys do an md5 or some other signature to look for duplicates?
  3. Something else even weirder.

This observation now has a picture of a stuffed toy !

https://www.inaturalist.org/observations/21568381

0 Likes

#7

Ok, so these images i’m trying to load are big-ish 28mb each. Do you have a secret size limit on images that you don’t tell people about if they exceed?

0 Likes

#8

I shrank the images to 1.8 mb each and they loaded. So it might be size or it might be that they are technically different images since the signature will be different.

0 Likes

#9

Try loading the same shrunk images again to rule that possibility in or out…?

0 Likes

#10

So I tried loading the same image twice. It worked. So it looks like there is no check for duplicate images on the same observation, but there is a secret image size limit. If you exceed that limit, it breaks - there is no error message - it just craps out. My guess at the limit is around 22mb. There could be other reasons, but I’m not getting paid for this…Good luck

1 Like

#11

I do get similar issues from time to time, however I found them to be, in my case due to a faulty internet connection. This may not be your issue, but you could check how stable is your connection and retry. I have been able to upload fairly large pictures (composites of 3-4 pictures) without a problem provided that I have a stable albeit slow internet connection. Best of luck trouble shooting this issue.

0 Likes

#12

I’ve had the same issue before and it was due to file size - all of the biggest ones failed to upload. Even if all your photos are by the same camera, there can be pretty big differences in file size, so some will upload and some won’t. I use Lightroom so when I batch export my photos I will limit them to like 6mb. I’ve had some photos get up to 22mb and there’s just no good reason to have them that big for iNaturalist. I think it’s not unusual for sites to have issues with such big photos.

I never have issues with internet connection, just to dispel that idea - my upload speeds average 30mbps and I don’t ever have connectivity issues.

0 Likes

#13

just FYI. according to iNat staff, photos get downsized if they exceed 2048x2048px. so there’s probably not any reason to load even 6MB if it’s intended only for iNat. probably 2.5MB is the highest you realistically need for iNat.

see https://forum.inaturalist.org/t/enlarging-photo-on-identify-or-observation-page-very-slow/669/20

0 Likes

#14

Here’s the Lightroom export preset I use for iNat photos:

0 Likes

#15

Also, we have a 20mb limit per image.

0 Likes

#16

Ok so in summary.

There is a 20mb limit on individual image size uploads to inaturalist. If an image exceeds that the inaturalist uploader does not load the image and does not inform the user that the image exceeds the size limit.

I recommend you provide some feedback to the user that their image exceeds the size limit otherwise they have no way of knowing what went wrong.

4 Likes

#17

Agree 100%!

2 Likes

#18

I’ll make an issue for this, thanks!

0 Likes

#19

Fixed here: https://github.com/inaturalist/inaturalist/issues/2202

This is what the new error message looks like:

0 Likes

#20

just being nitpicky here, but the “try cropping… this will happen to all photos on the server anyway” part isn’t exactly right. they get resized, not cropped.

1 Like