Make map border for scrolling through observations in "Explore" tab

When you’re in the “Explore” tab of the main page, make a border around the map or add another “non-map” area so, when in the Map tab, you can scroll up and down without making the map zoom in and out.

The Projects page has a border around the map in the Map tab, so that could be used as a model. Or an ideal place might be to the right of the list of observations since it seems unlikely anyone would use that area to navigate the map.

EDITED: I noticed that not all Project pages have the border around the map so that is not a valid comparison. But the area to the right of the Observations, I think, would still be a reasonable “scrolling” area.

i don’t understand this request. when using a mouse, if i click, hold, and drag a point on the map, i can move the map around without zooming in or out. or on a touch display, i can touch and drag. (some maps require a 2-finger touch and drag.) no need for scrollbars.

Can you share more information about your browser? In both Firefox and Chrome on Windows 10, I have a scrollbar on the right side on the Explore page which I can use as a “non-map area” to view the area below the map.

Also note that they’re already planning on recoding the Explore page, so any issues with scrolling will probably be taken into account.

1 Like

oh… you’re talking about scrolling the whole page up and down. as bouteloua noted, there’s already a scrollbar for the page. if you’re using your mouse scroll wheel to scroll up and down the page, just make sure your pointer is in any non-map portion of the page (including the scrollbar), and the page will scroll up and down just fine using the wheel.

I was actually referring to scrolling up and down through the Observations on the right side of the page.

I’m using a MacBook and Firefox and, at least in MacOS, there is no scroll bar on the edge of the screen (the screenshot goes to the edge of the screen that is visable). Since it has a trackpad, there is no wheel. And, yes, if I go over the observations, I can scroll those up and down but that then makes a pop-up of that observation appear on the map. I was thinking that the area to the right of the Observations could be used to scroll up and down through the observations without making the pop-ups appear on the map (which covers quite a bit of the map and forces that pop-up to load, slowing down overall performance).

Sounds like it must be isolated to MacOS. I tried it in Firefox and Safari and no scrollbar on the edge of the screen exists for either. It was just a thought but maybe it is not that major of an issue.


Same for me, on a MacBook using Safari.

1 Like

i don’t know anything about Macs, but i wonder if this applies?

1 Like

Thank you! Now I have a scroll bar. I never looked for the info before because I didn’t know there was supposed to be a scroll bar.


Yes, changing System Settings to display scroll bars should work for now (at least it does for me, using a trackpad).

Out of curiosity, because I never scroll down that list and rarely use the map view, what are you scrolling down the observations list for? Just trying to understand it more.

I wasn’t (you probably were not directing the question to me). I don’t know whether it’s coincidental or not, but I get a much better map view popping up (covering all the observations) than I did before getting the scroll bar. Before, I would often get a map view with none of the observations on it. That’s what I was happy about.


I have used it for various things, most times when looking at a Project page like Herps of South Carolina, to see what has recently posted. Also, when looking up a particular species, like White Arrow Arum (Peltandra sagittifolia) to see who is observing them and where they’re being seen.

1 Like

Easy solution, thanks. I’ve always had mine set to “while scrolling” and that has seemed to work well with other websites I’ve used; the scroll bar just appears when you get to the edge of the screen. It wasn’t doing that here so I didn’t think there was a scroll bar. Changing it to “always” does make a dramatic difference for this issue though and I didn’t think to try that. Appreciate the help!


Cool. I’m going to close this thread then.