Number of comments not properly translated in Russian on lists

I know it is not a major issue, but it wasn’t there before last update of lists. Instead of using correct forms of the word «комментарий» depending on number of comments it shows the plural form with “s” as if it was in English.

1 Like

Can you provide a link? - helpful to have one handy to use as an example when fixing the issue. Thanks!

Sure, this one is from

Another bug of the same kind is on the page “Your observations”, where the number of observers should be in a single form (наблюдатель), not plural (наблюдателей)

1 Like

It seems to be a new thing? I noticed it like a week ago or so. In fact there’re much more mistakes, this one just seems to be a bug.

that one can be fixed by anyone here:

Thank you, I tried to delete those, not sure how successful, but it says in history of edits that I did.

Translating to Russian and many other languages could be tricky, as Russian has not only “singular” and “plural”, but also other plural rules that are currently implemented in different libraries but not always respected by developers and translators: Chances high that “Наблюдателя” problem needs to be resolved in the code first, as the actual value needs to be communicated to the string as an input (but I didn’t log in to crowdin, just assuming).

1 Like

Sure, there were so many different problems associated with “1” already, it’s interesting and definitely it’s about code, for a person it would be harder to make a mistake in this example imo.

I’ll add this to my weekly report.


Thank you!

This should be fixed.

1 Like

Thanks @tiwane, it fixed.
I have another question: a new user mentioned in the comments today that “Help” page is not translated into Russian. I was surprised, but it seems to be true. Since this page is essential, I can translate it. May I send the translation as plain text to you? Or is the only working option?

1 Like