Observations stuck on "Waiting to upload..."

Thanks in advance!

iOS 15.3
App version 3.2.4,build 648

Description of problem
Today my observations will not upload; they are stuck on “Waiting to upload…” I’ve tried restarting the app and the phone, updating the phone’s OS, but nothing seems to work.

Step 1:
Attempt to upload/sync an observation as usual.

Step 2:
Observation stays listed as “Waiting to upload…” no matter how many times I try to sync.


2 Likes

Hmm. Are any of the dates of those observations in the future? That’s one common cause of this.

As an aside, are you taking photos with a dedicated camera? If so, I’d recommend using the web uploader rather than use the mobile app.

I have no idea why this happens, perhaps it’s related to the cache? (Got a weird error message about that a while back when I had the same issue) but it constantly occurs on Android app as well. Eventually they upload, but frequently I’ll see double of my observations on my app after it’s been stuck in “waiting to upload”. I’d love to see this bug get fixed, if possible.

This morning I tried to sync again and it worked no problem. This has happened twice in the last three days. But @tiwane’s comment made me realize: I just flew from Taiwan to BC and I wonder if my camera’s date is set to the “future” [… going to check …] yep, sure enough the camera was set to Taipei time. It’s on Vancouver time now, so we’ll see if the problem reoccurs. It’d be nice if the fix was this easy!


Similarly, my app has been showing ‘2 Observations to Upload’ for over a year now.

Just FYI - I’ve had no problems since changing my camera’s time zone from Taipei time to Vancouver time.

1 Like