Page 2 of Search results ignores part of search

MACOS 10.14
This search:✓&q=&search_on=&quality_grade=any&field:GG%20Invasive%20Plants&reviewed=&geoprivacy=&identifications=any&captive=&place_id=128172&swlat=&swlng=&nelat=&nelng=&taxon_name=&taxon_id=&day=&month=&year=&[]=&d1=&d2=&created_on=&site=&tdate=&list_id=&filters_open=true&view=map

correctly gives a full pge (200 results) of invasive plants observtions with the Field “GG Invasive plants”

Scrolling to bottom, there is a Page 2 of results. These do not have that Field, so are incorrectly included in the results.

Step 1: Enter Search URL as above

Step 2: Scroll to bottom of page and note the “Page 2”
That page has this URL address:[]=&taxon_name=&tdate=&user_id=941134&utf8=✓&view=map&viewer=941134&year=

ie the Field part is missing

I tried a screenshot but can’t show the full URL in it.

1 Like

It doesn’t help the bug, but as a work around you can reconfigure the search as

Thanks, I may do that, when I have time to recreate that search in Bulk editing… but I don’t think this thread should be marked Solved as its quite a serious bug?

And does that url find the page 2 of results, or just search only in page 2 of the observations?

Yes it finds both pages, but no that won’t work for bulk editing.

@tiwane is this a known bug, And if so is it on the list for debugging?