Problems trying to create a new place

Hello everyone,
this is my first post on the forum, and I apologize if perhaps I missed a place where to post an official “first” post…
I am having trouble defining a new place to use as a boundary for my project, the problem seems to have something to do with the limit of 50 verifiable observations, which I however do have…
Do I understand correctly that a “verifiable” observation is one with either the “Needs ID” or “Research Level” data quality level?
If so, I currently have 52 (but plan to add a lot more, I found in iNaturalist exactly the platform I was looking for).
Whenever I try to add a place (I see no “Add a new place” link as suggested by the Getting started guide, so I go to Places, search for my place, which doesn’t yet exist, click on the “Can’t find your place? Add a new place” link), I always get a pop-up yellow bar saying that I need 50 verifiable observations to do that.
Am I missing something obvious?

Thanks a lot in advance for your help!


Sorry for having spammed the bug report section, apparently it was just a matter of time… I tried again a few minutes ago, and I was able to create a custom place to use as boundary for my project.


Welcome to iNaturalist!

There can sometimes be short delays with things that rely on background indexing, especially during times of high site usage. When the City Nature Challenge is on, for instance, it can be a week before getting alerts on observations that are being watched.

While there will always be things that we want done differently, or think could run a little quicker, I am often amazed at how much functionality iNat has at such a scale of use. One fairly small) place I worked at had an in-house inventory system, and you could wait for 30 seconds after every commit before you could do anything else. I would pull out my phone and ID a couple obs after every press of the enter key!