Taxon map defaults to Pacific Ocean when a default place is set

I have chosen Southern Africa. But the map displays with Africa hidden off to the left.

Can you share a URL and screenshot? When you say you have chosen Southern Africa, where have you selected that place? Thanks!

an URL
https://www.inaturalist.org/taxa/508463-Pauridia

but screenshots I battle with.
My map on this taxon page has Africa partly visible at the left margin.

Set on Southern Africa as you suggested on a previous thread.
Top right below the search species box, I have a green pin Southern Africa.

Thanks, I can replicate:

Similar issue when I select United States, but only when I refresh the page after selecting the place in the top right corner:


https://www.inaturalist.org/taxa/71542-Hypoxidaceae

by the way, some instructions for taking a screenshot here: https://www.take-a-screenshot.org

1 Like

Resolved?

My Southern Africa default has disappeared.
My map now kindly defaults to the South-Western Cape for our fynbos species.

This is still happening if one has the southern Africa place selected:

When it should probably look like this (no matter what region is selected?)

The new tiles do make the map load faster, but they are hard to see. But if the map covered just the area that the taxon had been recorded, then if I saw the above map I’d know there were pins in areas where I would not expect them to be and can look harder ;-)

This map is for Drepanogynis, an African taxon, so I know the pins in the Americas must be misidentifications and I can go have a look.

Once I had fixed those 2 mis-IDs and removed southern Africa as the region, the map zooms to the area of recorded obs in southern Africa correctly.

2 Likes

7 posts were split to a new topic: Searching for Cape Town shows Cape Town Marine

Don’t know if it can be considered a bug, but it’s quite uncomfortable to use.
That’s a map for Sturnus vulgaris ssp. tauricus.

1 Like

i think this is just the way most online maps work so that you can pan either east or west infinitely. i suppose if the map automatically centered the map on the midpoint of the observations, then you wouldn’t see the observations twice in this case. is it not automatically centering for you?

1 Like

I wonder if it’s related to this? https://forum.inaturalist.org/t/taxon-map-defaults-to-pacific-ocean/4825

@melodi_96 do you have a “default place” assigned in your account settings or at the top right of the taxon page?

With no default place set, this is what I view on the taxon page:
https://www.inaturalist.org/taxa/730804-Sturnus-vulgaris-tauricus

3 Likes

I have removed the default place from my settings.

Instead of a whole world map centred on an uninhabited Pacific island, I get an informative useful map.

Ah, yes, that was it! Weird thing.

1 Like

I moved a few posts from your separate bug report to this topic. When I have no default place turned on, it shows me the zoomed in screenshot I posted above.

but if I change my default place to Europe, the map looks like this:

I would think it should show the zoomed in version in either case.

1 Like