This Whole Observation is Broken

This observation is not functioning properly

  • Research Grade for genus (despite “ID cannot be improved” status)
  • Changing the quality assessment doesn’t change the grade
  • The observed date is often not listed
  • When the date is occasionally visible, it is shown to have been observed after it was submitted
  • Despite 3 agreeing IDs, there is no community ID
  • I think that research grade bar near the bottom right of the page is also screwy but I can’t figure out why

Does anyone know why this observation is like this? Is it supposed to be like this??

1 Like

the reason is that the observed_on date is in the future which causes ‘validation errors’ meaning the observation can’t save or update properly (hence all the issues you describe)

I know @kueda was working this week on fixing the root issue of observed_on being in the future which would fix this and other obs like it but I’m not sure the status of the progress he made


I encountered this on Guam where the observation failed to upload a half hour after I photographed the plant. The error noted that the upload time was earlier than the observed on time. I used my Moto G6 Android cell phone camera for the images and uploaded the images from the phone using the Android app’s select photo option. The phone was set to local time at GMT +10. I did not have the presence of mind to send the log file. I wrote off the issue as due to being across the international date line from California. I changed the time to 24 hours earlier and the observation uploaded. I am still on the road, on mobile, and have not gotten back to a desktop to edit the observation and see if I can roll the time back to the correct time.

1 Like

My observation seems to be more broken than I thought, perhaps add this to the “This whole observation is broken” pile. The date displayed differs between screens:

Suggests a May 2, 2017 date?

Is what one sees when editing, and is the 24 hour advanced date. Am I missing something?

1 Like

I’ve been having some sporadic similar issues… made two observations on the iPhone app (test version) and tried to upload yesterday. Googled the error I got and it said it was time stamp related. Changed the date to one day sooner and they worked. But for a while I had a “posted -10 minutes ago” (yes negative minutes) showing too. So something is weird with timestamping on the app or something.


Definitely my fault. Regarding, I have a fix committed, but I’m not in a position to update the site right now. Hopefully we’ll get that out there on Monday.

Charlie’s error sounds unrelated, but to address that, as always, it would help to know exactly what observation(s) you’re referring to (i.e. URLs) and screenshots of the errors.


i have a screenshot on another phone that shows a -10 minute date for an observation, but as that’s since changed i’m not sure it is of much help.

That fix did get deployed and the obs linked in the original post is looking ok to me now. Is anyone else still experiencing problems like this?

Correction: is anyone else still experiencing problems like this that can’t be fixed by faving and unfaving?

Faving and unfaving seems to un-RG the observation, but not necessarily fix it all the way? Such as this one that @JeremyHussell mentioned. Shouldn’t it be RG for subspecies now?

That’s a separate issue:

I don’t think it is. The observation has only two IDs, both of which are to subspecies. The observation taxon is subspecies. Yet, the observation is still needs ID. I don’t see why it isn’t RG.

Agree, that doesn’t seem right, and I don’t see any DQAs in that obs that would be causing this.

I just made a manual ID (entered name rather than ‘Agree’) and it moved to RG, and removing my ID leaves it at RG…