Unable to leave a project

Platform (Android, iOS, Website): All

Browser, if a website issue (Firefox, Chrome, etc) : All

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/projects/tribble-mill-park

Description of problem:
When I try to leave the project at the url above, or through the mobile app, and click confirm on the pop-up, the UI will show that I have left the project only until I refresh the page. The project will still show that I am a member in all platforms. I have tried multiple browsers and mobile apps, all with the same result.

screenshots of what you’re seeing would really be useful. from my end, i don’t see any evidence that you are a member of the project you referenced.

If you’re trying to remove your observations, they have to be removed separately from your membership. You can “batch edit” observations to remove multiple at once

1 Like

Still a member when I click in.
76 obs - half of the project.


Showing me in the project:

Confirmation when I try to leave:

After clicking confirm:

After refreshing the page:

ok. so just to clarify, if you go look at the member list on the web version of the project page, you’re not there:


the fact that your observations show up when the project is defined as “project members only” is technically a different problem.

i suspect there’s some sort of indexing issue between the project and the database. (it looks like you’ve probably been removed as a member from the underlying database, but the project index didn’t get updated for whatever reason.) i would recommend joining the project again, and then leaving the project from the website (not via the app), and see if that fixes things.

1 Like

Thanks, that worked! I had to leave like I showed in the screen shots, but before refreshing I rejoined the project. Then I left again through the website and now I’m fully removed.


for iNat staff looking at this – you all have noted that it’s best to leave projects via the website, which i assume means that you know the apps can be flaky. i assume the app involved in the problem here. so maybe if anyone’s looking into potential problems, maybe this was a case of it.

1 Like

For the record, I did originally leave through the Android app from this project view, with a separate issue of being partly cut off:

1 Like