Upload problems in firefox (drag&drop)

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Firefox (latest, Linux)

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Click on “Upload”

Step 2: Drag and drop images you want to upload

Step 3: Drag additional images to the observations you want to upload

Observed result:
Expected result:
Images are added to the observation

It works in other browsers (like Chrome or Falcon under Linux), but it doesn’t in Firefox. I already disabled any plugins that could have caused trouble (like adblockers etc.)

I’ve also had this problem but it seems to work once the metadata has finished loading, so I just find something else to do for a few minutes. I’m used to slow internet problems so I hadn’t given it much thought.

As a fellow Firefox on Linux user, I rarely notice any problems with drag & drop on the upload page.
I have had issues when uploading many images at once, but it’s difficult to determine if that was due to an iNaturalist bug or a slow internet connection.
When uploading only a few at a time, then waiting for the “Loading metadata” message(s) to disappear before uploading any more, I don’t have any issues.

Agreed that metadata being incomplete could be an issue -
@HinzundKunz can you test if this makes a difference for you?

see also the post " Metadata loading suddenly very slow"
I have the same problems with firefox on ubuntu 22.04. Very often another problem appears for me (only in firefox). The dropdown (dashboard, edit observation, …) on the top right of the dashboard ignores any input. No reaction in network, console, etc. of developer tools, any selection is simply ignored. Restart of the page in a new tab does not help. I have to restart the browser in this case

I just want to make sure I understand this step. These additional images are not in the iNat upload page, but are being dragged from a folder in your computer directly onto a image that’s already in the upload page?

In my case it’s images already in the iNat upload page. I can usually drag some together right at first but then they stop and won’t move until the metadata has loaded.

If you drag a couple of pictures onto the upload page, it will create separate entries for every single image.
Then, I want to add additional images to one of the observations (different angle, zoom etc.), but it doesn’t do it, even after waiting for the “loading metadata” message to disappear. The same problem does not happen in other browsers.

Also it doesn’t make any difference whether I only want to upload only one observation or many.
And I tried it in a private firefox window as well to make sure no extensions are loaded, but that doesn’t make a difference either.

Here’s a screen recording of me using Firefox 124.0 (my standard browser, with extensions) to upload four photos of the same lizard and combine them using drag and drop, which worked OK on my computer. Is this the method you’re using?