Upload screen stuck on 'Uploading 1 of X photos...'

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc) : issue happens on both Opera and Chrome

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):


Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Spent time adding photos to the upload screen, finalised all IDs and clicked the green submit button. Despite the photos having sat there for 10-15 minutes, the pop-up was stuck on ‘Uploading 1 of x photos…’

I waited another 5 minutes, nothing loaded. I refreshed the page, reloaded everything and tried again, same problem. Tried in Chrome (vs in Opera initially), same problem. Tested it with photos from a different folder on my computer (including photos that I have previously uploaded to iNat), same problem. So it doesn’t matter what I try, but my upload screen is stuck on this.

Uploaded an observation via the iPhone app and it worked perfectly.

Just did another attempt, problem still exists

tried it again, but this time uploading just a single photograph, and it worked. Will test out uploading two pics next

EDIT: Tried uploading 2 pics/observations at once, and it remained stuck on uploading the first photo for 15 minutes (then I closed the window)

EDIT 2: 40 minutes of loading now, and those two observations are still stuck on the same screen

EDIT 3: heading off to bed now, but it’s now been loading for 65 minutes without working

open up your browser’s developer tools and see if there are any error messages in the console.

has the same photo been in the first observation in each of these sets that you’ve tried to load?

Will check for error messages tomorrow when I’m back on my computer (on my phone now)

Re your second point, no, I’ve tested multiple different unique photo sets from different folders and dates

I’ve had this happen before, I agree it is very frustrating. Shutting down my computer and starting all over again usually seems to fix it, except the lost work.

tried uploading again this morning, still won’t work. I’ve got the console open

the only error i see in the console is something related to a Google tracker being blocked by an ad blocker. that probably shouldn’t cause the page to behave strangely, but you could try turning off add blocking temporarily to see if that changes anything.

there’s also more information if you look at the Network monitor. you’ll need to have that open prior to starting the upload though. that will show all the requests that your browser made and how long it look to complete each request. if you see anything that took a long time and is still running after a long time, knowing what that is could help narrow the search for issues.

I had a go earlier this morning with the ad blocker off, but it didn’t help

an ignorant question, but how do I look at the network monitor?

next to the Elements tab at the top of your Developer Tools screen, there a double arrow pointing right. click on that, and you should get a list that includes Network. click on that. then try redoing your upload while the network window is still open.

1 Like

sorry for being a pest, I’m not super tech savvy. Here’s the network

and ordered by time

hmmmm… not sure. is there anything that didn’t complete yet on the list?

if everything on the list completed, then i’m not sure how to troubleshoot further without actually doing some debugging on your machine. did you already try to restart your machine and see if that solves things?

I restarted my computer, that didn’t work

Only one thing on the list is not finished, so presumably this is the root of the issue?

So I just tried uploading a different batch of photos compared to the previous batch, and they are loading now, but glacially slowly compared to normal

okay… so request to photos might be where the issue is. for each photo, i think there’s a post request to iNat to create the photo in the system. if the request is pending, i think that means it’s still running, but it’s just taking a long time. i can only guess there might be something between your browser and iNat’s servers that’s causing things to process really slowly.

(my uploads seem to process just fine.)

1 Like

unfortunately this only seems to happen for some random photos (i.e. that they load slowly, but they are indeed loading at all); a batch I tried last night sat there for more than an hour still stuck on the 1st pic

I’ve also got the issue on both opera and chrome

tried things now with another new photo batch, back to not loading at all. New error messages now though

these are both based on Chromium. so i wouldn’t expect there to be a difference necessarily, even if the problem originated in your browser. if Firefox also exhibited the same thing, then i think you could definitely rule out your browser for sure as the cause.

that said, i would guess this kind of issue probably originates with your ISP. not sure what kind of service you have, but my service can be randomly flaky sometimes. some requests process really fast, others slow (not as slow as what you seem to be experiencing, but unpredictable nonetheless).

those error messages are related to Google Maps. so not necessarily something i’d be concerned about here. but do you still see any pending requests to photos or other requests that haven’t completed?

(i’m going to jump offline for a while, but i’ll check back later.)

1 Like

I still have this single pending ‘photos’ item

while also noting that the individual ‘photos’ items that appeared for the previous batch that did load (the ones that took >1 min each to load in my previous screenshot) have not appeared this time around

this upload issue is the only problem I’m having at all right now. Every other thing (including all other parts of iNat) are working as usual