Broken link to forum topic from iNat dashboard

Occasionally I get this error when trying to open a forum topic from the iNat dashboard:

This just happened trying to open the recent scheduled downtime topic:
https://forum.inaturalist.org/t/6-hours-of-scheduled-downtime-february-4-5/19835

Note that this is different from the link from the iNat dashboard:
https://forum.inaturalist.org/t/6-hours-of-scheduled-downtime-february-4-5

The only difference is that the dashboard link doesn’t have the post number at the end (if that’s what it is). All the other links on the dashboard right now open with their respective number. Why didn’t this one? Not sure if it’s a Forum issue or an iNat bug. I’m also not sure if there’s a pattern in the kinds of posts that this happens to, but it’s only happened a handful of times in the last year.

I also might add that on this page the dark mode “iNatForum” is the same color as light mode. This means “Nat” isn’t visible. It should be white like the rest of the site.

Screen Shot 2021-01-29 at 8.28.30 PM

Using Chrome on a Mac

2 Likes

I have recreated the bug on Opera GX. It seems it only happens for that topic.

You may see that message when a post was moved to a non-public form like a message, but I’m not sure why you would see that in this case for that post.

probably the same as what happened here: Forum link on iNat home page takes me to wrong thread - Bug Reports - iNaturalist Community Forum.

probably just an edge case (title begins and ends with a number). not sure if it’s worth trying to address.

EDIT: for what it’s worth, the workaround / fix would be just to add /:id to the end of the link to the forum topics, which probably would not be that difficult to do, but again, it’s an edge case. (the real fix is probably a fix to Discourse itself, in which case someone would have to report the bug over there and shepherd it through, assuming it hasn’t already been reported. if someone wanted to look into the latter option, it doesn’t have to be iNat staff to do that.)

1 Like

Maybe the link resolver is just a really strict grammarian, as numbers <10 should be spelled out in text (eg, “Six”)…;)

Not the same, in that case clicking on the link title Forum made you go to the iNat home page. This is different.

i think you’re confusing the thread that i referenced above with this one: Forum link on main page points to inaturalist itself - Bug Reports - iNaturalist Community Forum.

I meant that post… You linked it and I was explaining why that post and this post aren’t similar.

please clarify which post you’re talking about. are we agreeing that the first thread that i referenced above discusses the same issue as the original post in the discussion thread that we’re in right now?

No, I’m disagreeing and saying that the two posts are of separate issues.

ok. let’s break it down…

in the thread that i referenced earlier, you had a case where a link to a forum thread was taking you to the wrong thread. it looked like what was happening there is that because the title of the thread began and ended with a number, it looked like Discourse was redirecting you to a forum thread with the ID that corresponded with the leading number in the title of original thread.

in this thread, the OP is saying the link to the forum thread on the iNat home page is taking you to an error page in the forum. applying the same logic as above, since this new thread has a title that begins and ends with a number, Discourse is probably trying to redirect you to thread 6 (https://forum.inaturalist.org/t/6), which doesn’t exist, and that’s probably why you’re seeing an error page when you click on the link.

here are some example links that may or may not help clarify what i’m talking about:

1 Like

yeah, same issue as the first link pisum posted. this one is just redirecting to a post in a private admin category, so you can’t see it; post number 6 is apparently this:

1 Like

Ohhh, okay I see what you mean. Thanks for clarifying.

This happened again today, but with a topic title that changed in the forum before being updated on the iNat dashboard.
https://forum.inaturalist.org/t/catholics-wanted became
https://forum.inaturalist.org/t/documenting-biodiversity-on-catholic-lands/20248

Not sure if this is related to what happened before, but there also is no number after the previous title. It’s all caught up now though.