Can’t load observations that lack photos

Hi! Since yesterday, I’ve been unable to load observations that lack photos. I’ve been using a Fire tablet and an iPhone to select observations on the website, and I’ve encountered this problem when using FireFox and Chrome.

To see what I’m seeing:

Step 1: Pull up a page of observations.

Step 2: Go to Filter and uncheck “Verifiable.”

Step 3: Click on an observation that shows only a symbol, not a photo.

When I take these three steps, the observation I selected won’t load, and I’m presented with only a blank white screen. The problem persists even if I reload the page.


I’m having the same issue as of yesterday (6/21/24). Using Firefox on Windows 10. The only way I can navigate to my entries without media is by clicking the navigation arrows from entries that have media.


I can replicate in Windows 10 in Chrome and Firefox. Going to a medialess observation returns a blank page, eg:

Happens whether I am logged in or logged out.


I have number of bird observations that are marked casual because there are no photos. When I click on the observation I get an empty screen. Is this right?

This should be under bug reports. It has already been brought up there

1 Like

Merged to bug report here.

This doesn’t seem to be the same issue as what I’m seeing. When I click a photo-less observation, I get only a blank white screen. (See the screenshot I added.)

No, it’s the same. If you click an observation without a photo in the identify tab it appears like the top screenshots there, but if you open it in a separate window/tab it is completely blank.


Getting same problem, Linux, both Firefox & Chrome.

On Firefox (my normal browser) the browser console shows an error:

TypeError: is undefined

Don’t know if that’s helpful.

1 Like

looks like the probable source of the problem is a small change to the web photo browser that was part of a larger set of changes related to what appears to be a Natural Language Search demo (ex. search for: “A yellow bug with black spots”).


I’ve the same problem on Firefox and Edge, Ubuntu 22.04.

Yes, same problem for me too, on MacOS and Firefox. Observation pages without media are not loading.

I received a notification yesterday about a (medialess) observation in a place I’m following. As noted above, the observation won’t open, I get a blank white display. I tried looking at the user’s profile, but that also doesn’t display. Clicking on their user name takes me to an “Observations” listing page, with “0 observations, 0 species, 0 identifiers, 0 observers”, and “No results found” underneath.

I don’t know if the user has any other observations. Even if this was their only observation, shouldn’t the profile page open and show their details? Or have they maybe deleted their account since making yesterday’s observation?

Additional info: I tried searching for the user via the “People” page, and their account does still exist. From there I could open their profile, and see that they only joined iNat yesterday. They do have other observations apart from the one I was notified of, but none of their observations have media.

PS: and then I realised that clicking on the user name on any notification doesn’t take you to the user’s profile, it takes you to their observations. So that explains the behaviour I mentioned in the previous post.

@loarie sorry to bother you but this seems quite big. Will the bug be fixed soon? I’m anable to load causal observations from fryday.

looks like this has been resolved, although i wonder if optional chaining and nullish coalescing could have simplified the fix?

instead of:

    const photos = (
      && this.galleryRef.current
      && this.galleryRef.current.props
      && this.galleryRef.current.props.items
      ? this.galleryRef.current.props.items
      : [];

maybe something like this:

    const photos = this?.galleryRef?.current?.props?.items ?? [];
1 Like

It is working for me now, too.

1 Like

Yes, working now, thanks.

1 Like