CC-licensed images not loading, and then painfully slowly in South Africa

Platform (Android, iOS, Website): website

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Images are loading painfully slowly, if at all. Since yesterday

Step 2: Have now disabled Privacy Badger, but that has made no difference.

Step 3: Refresh. Wait. Switch off and start again. I can’t work thru IDing Unknowns, or use iNat when it is so slow. Hoped something would have resolved overnight - it’s maybe a little less slow but still agonisingly slow.

Not in USA so this service provider AT&T doesn’t apply

1 Like

Another thread - but I don’t see a solution I can use.

But apparently the conflict between pictures hosted at Amazon and not landing here?

That picture still needs to load the bottom strip.

Photos load for me in 1-3 seconds. Even with observations of kingdom rank ID - I thought the many pins on the map might be slowing things down but the photo loads. But the pins themselves load slowlier - sometimes up to 8-9 seconds for rank kingdom in the USA.
Chrome on Win 10 here.


for what it’s worth, i don’t see any slowness on my 5G connection in the USA. i also tried going through a VPN going through Europe and Asia – i don’t have an option to go through South Africa – and that worked fine, too.

do you see a difference between the loading times for the photos in these 2 observations?

the first is unlicensed but the second is licensed NC-BY. so the photos will come from different servers.

if there’s no difference, then i would think that your connection is just slow.

if only the second one load slowly, then it has something to do with your connection to Amazon’s servers specifically.

in either case, you could try resetting your modem and computer, and if that doesn’t fix things, then you might need to call your ISP to troubleshoot.

1 Like

Thanks - the first is good - and yours is coming thru a strip at a time, as if painting a wall with a toothpick.

okay. so then there’s something wrong with your ISP’s connection to the AWS image set specifically then. it’s possible they’ve purposely throttled it. maybe they have limited shared bandwidth and think that activity associated the image host is consuming a disproportionate share of the traffic, or maybe it looks otherwise suspicious? or maybe they just have a bad connection to the AWS server? in any of the cases, it’s probably best to call your ISP to resolve whatever the problem is.

tell them you’re having trouble loading images from iNat’s AWS image set. for example:


I am having exactly the same problem. It started yesterday afternoon.

The site is unusable. Only © images load, all the amazon-hosted ones do not, or they take literally hours to load. This is on Brave, LibreWolf and Firefox on Linux Mint 21.

I kept checking the forum to see if anyone else was having this problem, found nothing (except the linked thread above which has been marked as solved), been on the phone all day with my ISP. They cannot find a problem.

Edit: Have checked logged in and logged out - same image behaviour occurs.
Have restarted machine and browsers - no change.

Edit 2: iNat is not the only site I’m having this problem on though!

1 Like

You are braver than I am. We have, previously spent hours on the phone to Telkom, chewing up mobile data. Our internet works otherwise (FB is also fairly data and picture heavy)

I will see how it goes, but maybe time for me to withdraw from intense iNatting.

Or Plan B - perhaps since iNat is international it needs a light mode alternative for Third World slow and erratic internet. I use that for my Gmail for example. I don’t need the map to load, until I click on it.

1 Like

@karoopixie – i assume you both use the same ISP?

unfortunately, i think the problem is probably at the ISP. if you can just get the right technician, they should be able to check to see if is on some sort of blacklist, and then they should be able to remove it if it is (or instruct you how to whitelist it in your setup). i’d be willing to bet that’s what the underlying issue is.


This does sound like similar issues that ISPs in both the US and Mexico have had with images in the iNaturalist Amazon Open Data Set (all iNat images are stored on Amazon Web Services servers, but if they have a CC license they’re stored in separate “bucket” with a different domain.). I changed the title of this thread to better reflect the specific situation that seems to be occuring here. There unfortunately isn’t much we can do about it.

One thing that seemed to work for Mexican users was changing their DNS service to Google. The instructions there are specific to Telmex and in they’re in Spanish but a quick Duck Duck Go search shows there are plenty of available instructions for changing one’s DNS server. Might be worth a try.

Are you able to load some of the images @pisum linked to on a mobile device when it’s using mobile data and not wifi? If so, do you have a different mobile ISP than you do at home?


Perhaps @karoopixie can answer the mobile ISP question?

I only use a camera, then my laptop at home.

1 Like

For what it’s worth, the AT&T issue seemed to be tied to a “false positive” with BitDefender:

I don’t use Telkom, but I think my ISP does use some of their lines/data along with other providers. They are not answering my msgs right now. Will try again in the morning after loadshedding. If it’s not one thing then it’s another. Luckily we are a hardy and adaptable lot :rofl: :crazy_face:

I will pass on all the info that all the helpful people have kindly provided here to my ISP tomorrow.


I don’t have cell signal, so can’t check on the phone. Sorry…


Mine in Cape Town is now, only a little bit slow, and I am catching up with some of the missed day’s identifying.

1 Like

My ISP may be small and rural, but I know where they live {evil grin}.

So, they have been able to fix this problem for me by moving me off any Telkom lines and putting me onto Vodacom fibre. iNat now works as expected {joy!!}.

I asked them if they would alert Telkom to the problem and ask them to fix it (because I thought they may have more of a hotline to them than the average customer - I was wrong :rofl:). They say it’s too much of a mission to get through to Telkom and speak to a person who actually knows what’s going on. So, no change there then… If it was a problem with FB or something which Telkom staff are likely to be directly affected by, then I’m sure they’d fix the problem promptly.

Sorry, Diana, I am unable to help you. Except to suggest that you get off Telkom and find another provider. (Your comment about painting with a toothpick gave me a good chuckle, thank you :grinning:)

Hey ho and onwards!


Thanks @tiwane.
Resolved for @karoopixie.
Please close this.

1 Like