Licensed images are currently loading very slowly on Deutsche Telekom

Platform (Android, iOS, Website):
Website, Android

Browser, if a website issue (Firefox, Chrome, etc) :

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Since yesterday images on the website are loading very slowly. This concerns all pages I’ve tested (individual observation pages, taxon pages, explore pages). Even the small (standard) images take pretty long to load, and when clicking on images to see them magnified, it takes ages. Other content of the website doesn’t seem to be affected (text, maps etc).

Anyone else experiencing this issue? I have pretty fast internet access, so this is definitely not the cause.


It’s been working fine for me, and we haven’t received any similar reports via email so I suspect it’s a local issue, maybe with an internet service provider. I assume you’re using a home wifi network? What happens if you use mobile data?

Do you see any loading differences between and ? The first is all rights reserved, the second has a creative commons license, so they have different domains. Sometimes ISPs treat them differently or block one.

My current internet speed is > 90 mbps (download) and 50 mbps (upload), and I’m using a Windows computer connected via LAN cable.

Your 1st link loads fast, the 2nd slowly.

1 Like

It sounds like your ISP might be throttling, which is where most iNat images are served from. There isn’t much we can do about it, I’d recommend reaching out to your ISP and asking them if they are doing anything special with that domain. See a similar situation from 2022.


I’m with German Telekom, the largest internet provider here, and I would be very surprised if they would be throttling specific domains.

I am glad you opened this Report -I am having the same issue (of images loading very very slow), browser independend, otehr websites work fine; I am located in Göttingen, Germany.

1 Like

No issues for me in the USA these last couple of days. I used to work in the network service provider world, and managed bilateral peering arrangements for a while. These are the business agreements that allow content providers, ISPs, network services, and others to trade traffic - it defines who pays the bills on these important connections.

It’s possible that whomever German Telekom is using to reach AWS (likely, it’s direct w/ AWS) is congested. I’m just pontificating, but it’s not uncommon for service providers and content providers to enter stalemates when negotiating who pays for these interconnections. This leads to these interconnections becoming congested, until one side blinks and agrees to pay for increased capacity. It’s also possible that one or more of these interconnections is down, or experiencing other conditions that are leading to congestion, such as misconfigured routing policies.

I agree with the suggestion to reach out to German Telekom, because it may still be something within their control.


Are you using German Telekom?

1 Like

I was having this issue last week as well - I just put it down to something odd with my connection but it was otherwise fast and all other websites loaded quickly. I haven’t noticed any issues today but if it happens again I can check anything that would be helpful
(in Cairns, Australia)


I’ve been having the same issue specifically on the app but it’s been going on for at least a few months as far as I can remember.

my internet is pretty slow, but it happens even when other sites load images straight away, and when it happens, it’s often that images for specific observations load very slowly or won’t load at all no matter how many times I try even though other observations load perfectly fine. I’ve had the problem both on wifi and on my mobile network

1 Like

I’m having an issue with my browser where it won’t let me upload photos at all. I’m going to try clearing cookies and possibly using a different browser (using Chrome currently) but every upload I’ve attempted from my desktop computer in the last 4 days has failed.

EDIT: Clearing my cache fixed the issue.


I’ve also experienced this from time to time, and I’m located in Norway. Earlier this week I tried to help out by IDing Odonata observations in Scandinavia, but this turned out to be a rather time-consuming task when I had to wait for each picture to load. Everything else on iNat and other sites seemed to load as usual (Windows 10 and Chrome).

1 Like

yes, also with German Telekom, but I tried it today at another flat, also with Telekom in the city and it was fine - will try again tonight if the problem disappeared at my flat, too.

1 Like

I was also having this issue last night here in Iceland - slow enough it put me off continuing to identify.
Didn’t notice issues on any other websites, and not something I’ve run into on iNat much previously as far as I remember.

Thanks all, I’m sorry some of you are experiencing slow image loading.

What we really need in order to investigate bugs are specific details, like URLs of pages where you experience this consistently, and whether it happens across different browsers and networks/internet service providers, if you’re able to test that out.


Hi Tony, I’m experiencing the issue again:

  • on a Windows PC with Chrome, connected through fibre / LAN (German Telekom)
  • on an Android phone (Google Pixel 7) and Chrome, both when connected through Wifi (German Telekom) and mobile data (Congstar, which is a subsidiary company of German Telekom).

For instance, this full-sized image takes ages to load:

1 Like

Dear tiwane
Message from Austria: Since Thursday, facing the same problem: creeping download of pictures when looking up my own observations. When this finished, already the picture is zoomed to a maximum.
Input of observations: thumbnails of suggested names load for ages before shown

Actions: updates on WIN10 and Chrome
System: WIN 10
Browser: Chrome ( both updates latest version)
Upload: >260 mbps
Download: >29 mbps
Cache 12 GB, used 6 GB after eliminating browser data in Chrome.

Firefox on same system better performance but not as fast as before Thursday.

Ubuntu LINUX: no problem and similar data on up- and download.

Service line of A1 Internetprovider will be awake by tomorrow

1 Like

That picture is loading in strips of pixels for me too.
Website - Chrome - Cape Town

1 Like

Also have been having trouble with images loading on the app for iPhone.
iOS - 17.2.1
iNat - 3.3.1

We also have this issue. However, it is most obvious in a Sunday afternoon CAT for some time now (several months). As some of the above replies implies.

1 Like