Observations failed to add to Habitats (s Afr) project in web uploader

When uploading observations, I always add to Habitats (s Afr) Project. Yesterday and today all observations failed.

No option to return to the observations about to be uploaded and try again. Obsservations have to be added afterwards.

1 Like

I can replicate. Does it happen with any other traditional projects? So far only Habitats (sAfr) seems to be affected for me.

Not with the others I used.

It is also not adding first try when adding afterwards. I also noticed the Fields are duplicated afterwards.

1 Like

I have always found that glitchy. I add my obs to the project afterwards.
Even if iNat accepts the project, I have to add Fynbos afterwards - that is never accepted before obs is loaded. My photos load slowly, maybe it is a timeout issue from our slow internet?

I’ve had the same issue before while uploading from here in the US!

1 Like

The habitats field is required for the ob to be included in the project. If you perhaps forgot to put the field in, then the obs would not have been added to the project. I mention this because, even though not all my obs are added to the project, I don’t get the same error message you see (I don’t get any notification at all). Then I wonder to myself if I perhaps forgot to add the project on upload.

I have many issues when uploading obs, especially with projects. I find my obs added to projects that I would not have added them to. I find that if I add an ob to the project “Interactions” it constantly defaults to “iSpot integration” - drives me nuts! But I digress.

1 Like

I am uploading hundreds of observations, and I have not (yet) had this issue. And I often load batches where some are Fynbos, others Afromontane Forest, with some Dwellings, Wetlands and Urban Parkland thrown in.

The Habitats (s Afr)* Project is to manage the Habitat (s Afr)* Observation Field. If you do not add the Observation Field on the Upload, the Project will always fail.
The message above is correct: the observation was not added to the Project. The real issue is: was the observation added to INat? If it was, then iNaturalist is working perfectly!
((you should get exactly the same in a Batch Edit)).

Note in the Upload Wizard, you can add the Project and the Observation Field in any order. Just so long as when you hit “submit”, every Habitats (s Afr) Project has a Habitat (s Afr) Observation Field.

The same is true of any other Project that has (a) compulsory Observation Field(s)
. - . - . -
*: yes it is logical: the Project contains dozens of habitats, but any one observation can only have one habitat.

Am I correct in that these are consecutive options in your project basket? Are you perhaps just mis-mouse-clicking? (I get it quite a lot with IDs, and get a wrong ID that can be quite embarrassing … - How on earth it slips past my noticing is beyond me)

No, it is not misclicking. I will send you an email. Not that you can do anything about it. I will need to contact iNat about it. I think it has something to do with the letter case? Anyway - different issue altogether, so let’s not get sidetracked ;-D

Please on the long winter nights - fix these:

Your observations with Habitat data that is not in a project:
& then:
Your observations needing a habitat:

Always been adding to the Project and completed the field. Never before had any issues, only the last 3 days. Yes, failed to add to Habitats Project again tonight.

I tried to do a batch edit before, but it did not work for me. I add the project by opening every observation and adding. Really big pain! First try the field will add and the project fails, second try the project is added. Afterwards the field is duplicated… see grab below.


Here is an image taken before trying to add to Habitats project afterwards. You will notice no projects, but the field is completed.

It would be helpful to know exactly what your observation looks like in the uploader before you hit Submit. Can you please share a screenshot that confirms the field has been added to the observation? eg

I had it again last night, Habitats (s Afr) did not upload to the entire batch.

I selected all observations to be uploaded, selected Habitats (S Afr) and completed the field Habitat (s Afr) by selecting Afrotemperate Forest.

I include snips made. It was not possible to get a snip to show that the Project and Field were completed. The message to inform me of the failure came up after selecting to upload and after a short interval the message ’ Going to your observations’ appeared. No option to go back and retry to add to the project and no way to stop the process.

Please give me the instructions to do a batch edit and add the observations to the project. I am missing the point where the field can be completed. I select the observations and choose the project and then get a message the observations failed to add to the project, as the field is not completed.

I did add the Boxkite Spider observation to the project afterwards, but it will be great to do a batch edit instead of opening each observation and adding it to the project.




1 Like

I’ve been having the same issue with my last three uploads. To vouch for my steps I had an observer witness the process. In the batch edit afterwards the Project Edit option reverts to the Project page itself.

And have had intermiitent snarl-ups with the left hand side of the Upload page as per madastlucia

@tiwane Tony, it seems I am no longer the only one experiencing these problems.
See https://www.inaturalist.org/observations/37745455#activity_comment_3949967

I have had these problems when I work quickly. It sometimes takes several seconds to complete adding the required field. If you add it to the project before the field is saved then it will fail.

My observations have failed to add to the Habitats (s Afr) project on four occasions now; twice last night (18/01/2020) and then twice again today. I have to add the project and fill out the necessary observation fields to each observation separately afterwards - and this still takes more than just one try.

Just uploaded 14 observations and adding to Habitats (s Afr) project failed again.

At last the grabs to show the project selected and the field completed!

Please note at the top, select all is ticked.




Magda, Jeremy, Andrew, Sandra - please bear in mind that we have rubbish internet at the moment, and I’m surprised you guys can load anything at all! It has taken me 1.5 hours just to load this page!

1 Like