The new Android app version now uses a very restricted photo picker

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): 1.29.7 (581)

Android version Motorola S3SV32.45-28-1-6 applied on 09 July 2023

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Create a new observation

Step 2: Select Image

Step 3: A severly restricted photo picker appears, it only shows a few last photos taken. Maybe the other ones are accessible by traversing the directories, but that is extremely slow, clumsy and without the preview, it is basically impossible to orient in the thousands of photos taken.

This is what I get from iNaturalist:

This is what I get from PlantNET now and what I used to get from iNaturalist before:

Yes, you can share a photo with iNaturalist from some app instead.
No, you cannot use that to add new photos to an existing (even if not uploaded yet) observation.

This makes it practically impossible to upload any significant number of observations from the phone now. Maybe, installing an older version may restore it, but otherwise it is now observations in the future ar much fewer of them.

1 Like

Closing to focus discussion on the existing topic:

OK, my report was closed so I will reference it here

I would like to stress that the problem I tried to make attention to is NOT just in getting the location.


Actually, I do not even know get access to the photos I would like to add in the first place! It is really important to get the access to the other gallery apps.

It is also important to note that it is NOT caused by Android system update but really by the iNaturalist app update and that other apps on the very same phone are still fine and the last system update happened months ago. Maybe it comes from binding the app with a newer Android API.

I think an older version from apkmirror or similar is the only way to get a functional app at the moment.

Also, there isn’t really any “Browse” available in the menu. The picker does really only show a few last photos and nothing else.

I would like to update that while reverting to 1.29.4 does not get the location back, it does get access to the other Gallery apps that are necessary to actually get to those photos at all.

Since this is clearly a different issue, cannot my report be re-opened?

Sorry, you’re correct in that this is a different issue. However, the version you mention in your original post is a beta release version of the app, so you must be a beta tester. And beta versions often have bugs in them, including this one, which we’re aware about.

If you want to leave the beta testing program, go to Then you’ll be getting the public version of the app, which is currently 1.29.5 (579).

1 Like

I am sorry, but the latest version 1.29.14 has the exact same problem. There is no way to get to the better Gallery apps from the picker so selecting anything older than the last 64 photographs is very complicated.

I’m not able to select ANY photos!!


App version number, if a mobile app issue:

Screenshots of what you are seeing:

Description of problem:
Mobile iNaturalist stopped showing me the Gallery option when I go to upload images. It is way easier to find pictures scrolling in Gallery, especially when I have photoshoots that aren’t recent.


Which version of Android OS is your device running? Which device are you using?

I’ve just updated the app from 1.29.11 to 1.29.14 and the Gallery option disappeared for me too (Android 11).

I use a Samsung Galaxy S22 Ultra. The Gallery option appeared for me prior to the last update.

The same thing also happened to me (and the Photos option is gone too). I have a Pixel 6 Pro running Android 13. The app is 1.29.14.

1 Like

Same problem here. Motorola 2023 G Power 5G.

I’ll take a look today.

OK, I made a github issue here:

I think it is the same as You wrote you were aware of the issue.

I’m having the same issue - I can’t upload ANY photos! So frustrating!!! The desktop version is awful and irrelevant. Is there any fix on this? I’ve tried uninstalling and reinstalling and no go.

There’s a workaround in the latest beta version, it’s looking pretty good but needs some tweaks. Unfortunately this is still related to Google’s new photo picker and their refusal to let apps import location data with the photos.

The iNat website is not designed for use on mobile devices, so if that’s what how you’re using it I understand - it doesn’t work well. On a desktop or laptop computer, the uploader works really well in my experience. See this tutorial: