Seek app can’t access photo library on iphone

This bug was reported to you via email recently but I figured posting about it here hopefully gets more attention and feedback.

Problem is the iseek app only gets access to the iPhone photo library once and no more.





Have you tried reinstalling the app for changing “all photos under the privacy settings for seek to “selected photos” and trying it, and then changing it back to “all photos” to see if there was just a small glitch? Also try reinstalling seek and then restarting your phone to see if that helps!

(changed the topic title since the app’s name is not Iseek)

If you delete Seek, all of your observations will be deleted as well. And now iOS doesn’t delete an app’s permissions if you delete the app, which is quite frustrating.

Unfortunately we haven’t been able to get to the cause of this bug, I’m sorry. Still working on it. If anyone else is experiencing it, please provide details.

1 Like

Are there any plans to keep observations and automatically sync into the app if the user logs in to another device, etc?

No, there aren’t.

In settings change photo access to none, the. Open the app and check photos (it should tell you it had no access). Then go back to settings and select all, then go back to seek. Go to the photos screen it may take a couple minutes to show your photos of you have a very large library.

This solved the issue! I have a huge photo library and it took my speedy iPhone se 3 about 20 minutes to load and show its content. A printer app (Epson) also access my whole library but in a matter of 10 seconds or so. So something about this process is taking more time than needed I guess.

A huge thanks to brettthepark for providing directions and the solution to the problem!

Update: Using the app today, no photos show up in accessed library, contrary to yesterday when I thought the problem was solved (see post above). Took some photos with apple’s camera app, this is the only thing that changed after being able to use the app fully functioning. Now no photos show. So back to square one.

I have access (see screen shot) but no photos are shown. I’m pretty sure they’ll load eventually, in about the same time as yesterday (20 minutes!). Meaning I’ll have to reload the whole library each time I want to use the app.

  • do you back up your photos to iCloud?

  • which format do you shoot your photos in? RAW, HEIC, JPEG?

All photos backed up to icloud, 2TB (about 200 gig free space left).

Mostly in HEIC, but many jpeg, raw and videos.

1 Like

Hmm, OK. I’ll try to take some photos in HEIC and RAW formats and see if I can replicate on my device. But if you use iCloud Photos, there should only be a thumbnail in your library, unless the photo(s) haven’t been backed up yet.

I’ve made sure icloud is updated and that my phone only stores the compressed ‘non original’ versions of photos.

Really thankful for your speedy feedback!

Thank you. I’ve taken HEIC and RAW photos and the gallery loads fine for me.

I’ve made an issue on GitHub here: https://github.com/inaturalist/SeekReactNative/issues/457

I just had the same experience where the app cannot reaches the camera roll library. I deleted and reinstalled the app but lost all observations, obviously. Thanks for helping get this bug solved!

For anyone experencing this bug: how many photos are in your library? Go to Photos → Albums and look at the number for the Recents album. We just got an email from someone experiencing this bug who has 43k photos in their library. I have about 5.2k.