API v2 feedback

If anyone’s interested in helping to test, I’m going to start opening up a test of v2 of our API on the obs detail page. You can test any observation page by appending test=apiv2 to the url, e.g. https://www.inaturalist.org/observations/71283655?test=apiv2, and curators will soon see a banner at the bottom of the page with an option to make the preference for v2 stick (and to opt-out).

In theory there should be no change in functionality, but in practice there are probably still some bugs.

If you’re curious, API v2 will shift from a static response schema to one that’s more customizable, which should hopefully allow us to save everyone on bandwidth by reducing API response sizes, as well as deal with a lot of stability issues in the mobile apps, especially on older devices with limited memory.


Are there particular types of bugs, or it could be many types of issues? Nothing seems to happen when you tick Yes or No to the last DQA question.


That kind of bug! Could really be anything. You’re referring to “Based on the evidence, can the Community Taxon still be confirmed or improved?” correct?

Yep! The other ones seem to work.

Not sure if this is a bug, but the Encompassing Places are sorted differently.

1 Like

I’m not getting anything in the Follow drop-down.


1 Like


  1. the vote doesn’t work. example error:
    • POST https://api.inaturalist.org/v2/observations?taxon_id=7428&order_by=votes&preferred_place_id=&locale=en&ttl=-1&fields=&photos=true&not_id=f1e8af8d-75ee-422d-a00f-a4bc77e3a1ce&per_page=6&details=all 400 (Bad Request)
  2. three errors on each page, which i think corresponds to the bottom sections of the page (more from, nearby, of relatives), which don’t load. example errors:
    • api.inaturalist.org/v2/observations?user_id=779571&order_by=id&per_page=6&details=all&preferred_place_id=&locale=en&ttl=-1&fields=&order=desc&id_below=70525256:1 Failed to load resource: the server responded with a status of 400 (Bad Request)
    • api.inaturalist.org/v2/observations?lat=29.7688631&lng=-95.4484492&verifiable=true&radius=50&order_by=observed_on&preferred_place_id=&locale=en&ttl=-1&fields=&photos=true&not_id=f1e8af8d-75ee-422d-a00f-a4bc77e3a1ce&per_page=6&details=all:1 Failed to load resource: the server responded with a status of 400 (Bad Request)
    • api.inaturalist.org/v2/observations?taxon_id=7428&order_by=votes&preferred_place_id=&locale=en&ttl=-1&fields=&photos=true&not_id=f1e8af8d-75ee-422d-a00f-a4bc77e3a1ce&per_page=6&details=all:1 Failed to load resource: the server responded with a status of 400 (Bad Request)
  3. computer vision suggestions seem to work, but they seem to lack nearby information and new nearby functionality.
  4. taxon autocomplete in suggest ID doesn’t work. example errors:
    • POST https://api.inaturalist.org/v2/taxa/autocomplete?q=tes&per_page=6&locale=en&preferred_place_id=&fields= 400 (Bad Request)
    • Uncaught (in promise) Error: Bad Request at thenText (observations-show-webpack-[number].js:131)
  5. taxon autocomplete also doesn’t work on a taxon-based observation field, with similar errors as above.

differences (not sure if these are bugs):

  1. default map zoom is different in this case:

… i’m sure there’s more, but that’s all i plan to do for now.

1 Like


apiv2 shows red cross at “identification is support by two users”, despite RG of the observation.
The same is happens with other RG-observations.

Also, new version shows incorrect order in standart places except the first one:

more bugs:

  1. the previous / next observation buttons don’t work (though maybe that’s intentional in the new design?)
  2. the Android / iOS app indicator logos don’t show up under the observation copyright
  3. selecting / deselecting the reviewed checkbox doesn’t work. example error:
    • api.inaturalist.org/v2/observations/6cccbffe-34dd-4dc5-a11d-f43daa109420/review:1 Failed to load resource: the server responded with a status of 404 (Not Found)
  4. join project doesn’t work. example error:
    • api.inaturalist.org/v2/projects/544/join:1 Failed to load resource: the server responded with a status of 404 (Not Found)
  5. adding observation field (yes/no type) didn’t work. example error:
    • POST https://api.inaturalist.org/v2/observation_field_values 404 (Not Found)
  6. can’t delete final tag on observation. (add 2 tags to an observation without tags. delete one of them. then try to delete the remaining one.) no console errors.
  7. editing an existing taxon-based observation field shows the numeric id of the taxon, not the name of the taxon. (could be related to the taxon autocomplete not working on taxon-based observation fields.) there’s also no x button to remove the taxon id, though since it’s just a number, i can backspace through it.
  8. deleting existing observation field (taxon-based) doesn’t work. example error:
    • DELETE https://api.inaturalist.org/v2/observation_field_values/2bf48ede-c203-4daa-a478-1e452dc67e2f 404 (Not Found)
  9. info section in pop-up when you click on observation field doesn’t show up. compare v1 on left and v2 on right:
  10. default annotations are different. here’s an observation with unknown taxon (v1 on left and v2 on right):

… i’m sure there are more, but that’s all i plan to do today.

1 Like

just 4 things this morning:

  1. the endemic / threatened indicators for taxa in the observation header and in the community taxon box don’t appear in v2 in some cases (not sure why the difference).
    see example below where it doesn’t appear, with v1 to left and v2 to right:

    here’s an example where it does appear:
  2. humans seem to be missing the annotations section altogether in v1 (left below), but they show up in v2 (right):
  3. v2 seems to be ignoring some user preferences. in the example below (v1 to the left, v2 to the right), note that the user has limited both project and observation field additions by the community, but there’s no indication of that on the v2 screen, and v2 still has a box to add observation fields:
  4. edit project settings seems to refer to undefined project:

… that’s probably all i’ll look for until a new release of the v2 API is deployed.

If I start here: https://www.inaturalist.org/observations/71338628, and I go down to the bottom and click in “Observations of relatives” on https://www.inaturalist.org/observations/3385395, I can consistently get a page with missing/not loaded elements:

but if I reload, the page, everything is restored:

I get the same results doing the same thing with other links, just wanted to give specific URLs to correlate to the screen shots.

Trusted users framework appears to be broken, I am no longer seeing the observation actual locations of users who have listed me as a trusted user. Seeing it as an obscured location including the buffer box.

Confirmed by switching back to V1 that I am still trusted and under that version I see the actual location.

Not posting a screenshot for obvious reasons.

Attempting to flag an observation fails under this version.

After hitting save, there is no error message or indication of any problem of any kind, but the flag is not saved.

Additionally, observations which are flagged are not displayed as such, at the bottom where normally there would be a link to view the flag there is just the link to add a flag.



Note - not a language issue as the behaviour is the same if I switch to English

in case it helps, several of the bugs i reported earlier seem to be related to my having no preferred place set up (for taxon common names). although i went back and checked only a few things i reported earlier, adding a preferred place in my account settings seems to make at least the following problems go away:

i had an error when trying to use the ‘compare’ button (old identotron).

It appears a repeatable bug at least in this case.

i can’t reproduce your error, although the site in general has been a little slow this morning:

if you still are consistently seeing the error, it might be useful to open up your browser’s developer tools to see if the error messages recorded in the console tell you exactly which request is failing.

since i was looking at this, i noticed another bug. the page shows common name (scientific name) even if you select to display only scientific name. there’s not a problem if you choose common name (scientific name) or if you choose scientific name (common name).

Jack Pine is not showing up as Vermont state vulnerable in this AP.

but it does when i turn it off.


as seen on https://www.inaturalist.org/observations/71743748

Adding an observation field value of “ID from genitalia” = “Si” fails on the v2 version but works when I switch back to v1. I tried it on the following observations (which currently have the value).


I’m getting ALL the options for everything in Class Insecta:

I was not able to mark “No, it’s as good as it can be” on the Community ID quality boxes during the API v2 version. I switched out of testing and it worked as normal. During the API v2 test, it would seem to roll a loading bar and then just stop. Nothing on the observation was changed even after refreshing, just to check.